Blob Blame History Raw
%define pkgname xsm

Summary: X.Org X11 X Session Manager
Name: xorg-x11-%{pkgname}
Version: 0.99.2
Release: 1
License: MIT/X11
Group: User Interface/X
URL: http://www.x.org
%define xorgurl http://xorg.freedesktop.org/releases/X11R7.0-RC2/everything
Source0: %{xorgurl}/xsm-0.99.2.tar.bz2
Source1: %{xorgurl}/smproxy-0.99.1.tar.bz2
Source2: %{xorgurl}/rstart-0.99.1.tar.bz2

BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

# FIXME: The BuildRequires are all missing here and need to be figured out.
# That's low priority for now though, unless we encounter real build
# failures in beehive.

BuildRequires: pkgconfig

# libxkbfile-devel needed for setxkbmap, xkbcomp, xkbevd, xkbprint
#BuildRequires: libxkbfile-devel
# libX11-devel needed for setxkbmap, xkbcomp, xkbevd, xkbprint
#BuildRequires: libX11-devel
# libXaw-devel needed for xkbutils
#BuildRequires: libXaw-devel
# libXt-devel needed for xkbutils
#BuildRequires: libXt-devel
# FIXME: xkbvleds requires libXext, but autotools doesn't check/require it:
# gcc  -O2 -g -march=i386 -mcpu=i686   -o xkbvleds  xkbvleds-xkbvleds.o
# xkbvleds-LED.o xkbvleds-utils.o -lXaw7 -lXmu -lXt -lSM -lICE -lXext -lXpm -lX11 -ldl
# /usr/bin/ld: cannot find -lXext
# libXext-devel needed for xkbutils (from above error)
#BuildRequires: libXext-devel
# libXpm-devel needed for xkbutils (from above error)
#BuildRequires: libXpm-devel

#Provides: %{pkgname}
Provides: xsm, smproxy, rstart
# NOTE:
#Conflicts: XFree86, xorg-x11

%description
X.Org X11 X Session Manager

%prep
%setup -q -c %{name}-%{version} -a1 -a2

%build
# Build everything
{
   for pkg in xsm smproxy rstart ; do
      pushd $pkg-*
      %configure
      make
      popd
   done
}

%install
rm -rf $RPM_BUILD_ROOT

# Install everything
{
   for pkg in xsm smproxy rstart ; do
      pushd $pkg-*
      %makeinstall
      popd
   done
}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root,-)
%doc
%dir %{_bindir}
%{_bindir}/rstart
%{_bindir}/rstartd
%{_bindir}/smproxy
%{_bindir}/xsm
%dir %{_libdir}/X11
%dir %{_libdir}/X11/app-defaults
%{_libdir}/X11/app-defaults/XSm
%dir %{_libdir}/X11/rstart/commands
%{_libdir}/X11/rstart/commands/@List
%{_libdir}/X11/rstart/commands/ListContexts
%{_libdir}/X11/rstart/commands/ListGenericCommands
%dir %{_libdir}/X11/rstart/commands/x11r6
%{_libdir}/X11/rstart/commands/x11r6/@List
%{_libdir}/X11/rstart/commands/x11r6/LoadMonitor
%{_libdir}/X11/rstart/commands/x11r6/Terminal
%{_libdir}/X11/rstart/config
%dir %{_libdir}/X11/rstart/contexts
%{_libdir}/X11/rstart/contexts/@List
%{_libdir}/X11/rstart/contexts/default
%{_libdir}/X11/rstart/contexts/x11r6
%{_libdir}/X11/rstart/rstartd.real
%dir %{_libdir}/X11/xsm
%{_libdir}/X11/xsm/system.xsm
%dir %{_mandir}
%dir %{_mandir}/man1x
%{_mandir}/man1x/rstart.1x*
%{_mandir}/man1x/rstartd.1x*
%{_mandir}/man1x/smproxy.1x*
%{_mandir}/man1x/xsm.1x*

%changelog
* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
- Initial build of xsm, smproxy, and rstart from X11R7 RC1