Blob Blame History Raw
%define fontname        sportrop
%define fontdir         %{_datadir}/fonts/%{fontname}
%define fontconfdir     %{_sysconfdir}/fonts/conf.d

Name:           %{fontname}-fonts
Version:        0.9
Release:        5%{?dist}
Summary:        A multiline decorative font

Group:          User Interface/X
License:        OFL
URL:            http://openfontlibrary.org/media/files/gluk/287
Source0:        http://openfontlibrary.org/people/gluk/gluk_-_Sportrop.zip
Source1:        %{name}-fontconfig.conf
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

BuildArch:      noarch

%description
A neat multiline font

%prep
%setup -c
chmod 0644 *.txt
for txt in *.txt ; do
   fold -s $txt > $txt.new
   sed -i 's/\r//' $txt.new
   touch -r $txt $txt.new
   mv $txt.new $txt
done


%build


%install
rm -rf $RPM_BUILD_ROOT

install -dm 755 $RPM_BUILD_ROOT%{fontdir}
install -pm 644 Sportrop.ttf $RPM_BUILD_ROOT%{fontdir}

install -dm 755 $RPM_BUILD_ROOT%{fontconfdir}
install -pm 644 %{SOURCE1} $RPM_BUILD_ROOT%{fontconfdir}/63-%{fontname}.conf


%clean
rm -rf $RPM_BUILD_ROOT


%post
if [ -x %{_bindir}/fc-cache ] ; then
    %{_bindir}/fc-cache -f %{fontdir} || :
fi

%postun
if [ $1 -eq 0 -a -x %{_bindir}/fc-cache ] ; then
    %{_bindir}/fc-cache -f %{fontdir} || :
fi

%files
%defattr(644,root,root,755)
%doc OFL_FAQ.txt OFL_License.txt tabl_c.jpg
%config(noreplace) %{fontconfdir}/63-%{fontname}.conf
%dir %{fontdir}/
%{fontdir}/*.ttf


%changelog
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild

* Sun Jul 27 2008 Jon Stanley <jonstanley@gmail.com> - 0.9-4
- Revert package split, package only TTF
- Use %%setup macro

* Wed Jul 23 2008 Jon Stanley <jonstanley@gmail.com> - 0.9-3
- Split OTF and TTF into subpackages

* Wed Jul 23 2008 Jon Stanley <jonstanley@gmail.com> - 0.9-2
- Fixed rpmlint warning in license and license FAQ

* Tue Jul 22 2008 Jon Stanley <jonstanley@gmail.com> - 0.9-1
- Initial package