Blob Blame History Raw
# Generated by rust2rpm
# * Tests are run in infrastructure
# * tokio-timer(dev) → tokio → tokio-timer
%bcond_with check
%global debug_package %{nil}

%global crate tokio-timer

Name:           rust-%{crate}
Version:        0.2.9
Release:        2%{?dist}
Summary:        Timer facilities for Tokio

License:        MIT
URL:            https://crates.io/crates/tokio-timer
Source0:        https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(crossbeam-utils/default) >= 0.6.0 with crate(crossbeam-utils/default) < 0.7.0)
BuildRequires:  (crate(futures/default) >= 0.1.19 with crate(futures/default) < 0.2.0)
BuildRequires:  (crate(slab/default) >= 0.4.1 with crate(slab/default) < 0.5.0)
BuildRequires:  (crate(tokio-executor/default) >= 0.1.1 with crate(tokio-executor/default) < 0.2.0)
%if %{with check}
BuildRequires:  (crate(rand/default) >= 0.6.0 with crate(rand/default) < 0.7.0)
BuildRequires:  (crate(tokio-mock-task/default) >= 0.1.0 with crate(tokio-mock-task/default) < 0.2.0)
BuildRequires:  (crate(tokio/default) >= 0.1.7 with crate(tokio/default) < 0.2.0)
%endif

%global _description \
Timer facilities for Tokio

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Fri Jan 25 2019 Josh Stone <jistone@redhat.com> - 0.2.9-1
- Update to 0.2.9

* Sat Dec 15 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.8-1
- Update to 0.2.8

* Thu Nov 08 2018 Josh Stone <jistone@redhat.com> - 0.2.7-2
- Adapt to new packaging

* Fri Sep 28 2018 Josh Stone <jistone@redhat.com> - 0.2.7-1
- Update to 0.2.7

* Sat Sep 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.6-1
- Update to 0.2.6

* Wed Aug 08 2018 Josh Stone <jistone@redhat.com> - 0.2.5-1
- Update to 0.2.5

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Mon Jun 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.4-1
- Update to 0.2.4

* Thu May 03 2018 Josh Stone <jistone@redhat.com> - 0.2.3-1
- Update to 0.2.3

* Tue Apr 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.1-1
- Initial package