Blob Blame History Raw
# Generated by rust2rpm
# Tests are disabled
# * tokio-sync(dev) → tokio → tokio-sync
# * loom isn't packaged
%bcond_with check
%global debug_package %{nil}

%global crate tokio-sync

Name:           rust-%{crate}
Version:        0.1.0
Release:        2%{?dist}
Summary:        Synchronization utilities

License:        MIT
URL:            https://crates.io/crates/tokio-sync
Source0:        https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(futures/default) >= 0.1.19 with crate(futures/default) < 0.2.0)
%if %{with check}
BuildRequires:  (crate(env_logger) >= 0.5.0 with crate(env_logger) < 0.6.0)
BuildRequires:  (crate(loom/default) >= 0.1.0 with crate(loom/default) < 0.2.0)
BuildRequires:  (crate(loom/futures) >= 0.1.0 with crate(loom/futures) < 0.2.0)
BuildRequires:  (crate(tokio-mock-task/default) >= 0.1.1 with crate(tokio-mock-task/default) < 0.2.0)
BuildRequires:  (crate(tokio/default) >= 0.1.14 with crate(tokio/default) < 0.2.0)
%endif

%global _description \
Synchronization utilities.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Fri Jan 25 2019 Josh Stone <jistone@redhat.com> - 0.1.0-1
- Initial package