Blob Blame History Raw
# Generated by rust2rpm-9-1.fc31
%bcond_with check
%global debug_package %{nil}

%global crate tokio-reactor

Name:           rust-%{crate}
Version:        0.1.9
Release:        2%{?dist}
Summary:        Event loop that drives Tokio I/O resources.

# Upstream license specification: MIT
License:        MIT
URL:            https://crates.io/crates/tokio-reactor
Source:         %{crates_source}
# Initial patched metadata
# * Update parking_lot to 0.8, https://github.com/tokio-rs/tokio/pull/1078
Patch0:         tokio-reactor-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(crossbeam-utils/default) >= 0.6.0 with crate(crossbeam-utils/default) < 0.7.0)
BuildRequires:  (crate(futures/default) >= 0.1.19 with crate(futures/default) < 0.2.0)
BuildRequires:  (crate(lazy_static/default) >= 1.0.2 with crate(lazy_static/default) < 2.0.0)
BuildRequires:  (crate(log/default) >= 0.4.1 with crate(log/default) < 0.5.0)
BuildRequires:  (crate(mio/default) >= 0.6.14 with crate(mio/default) < 0.7.0)
BuildRequires:  (crate(num_cpus/default) >= 1.8.0 with crate(num_cpus/default) < 2.0.0)
BuildRequires:  (crate(parking_lot/default) >= 0.8.0 with crate(parking_lot/default) < 0.9.0)
BuildRequires:  (crate(slab/default) >= 0.4.0 with crate(slab/default) < 0.5.0)
BuildRequires:  (crate(tokio-executor/default) >= 0.1.1 with crate(tokio-executor/default) < 0.2.0)
BuildRequires:  (crate(tokio-io/default) >= 0.1.6 with crate(tokio-io/default) < 0.2.0)
BuildRequires:  (crate(tokio-sync/default) >= 0.1.1 with crate(tokio-sync/default) < 0.2.0)
%if %{with check}
BuildRequires:  (crate(num_cpus/default) >= 1.8.0 with crate(num_cpus/default) < 2.0.0)
BuildRequires:  (crate(tokio-io-pool/default) >= 0.1.4 with crate(tokio-io-pool/default) < 0.2.0)
BuildRequires:  (crate(tokio/default) >= 0.1.7 with crate(tokio/default) < 0.2.0)
%endif

%global _description \
Event loop that drives Tokio I/O resources.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Mon May 06 22:01:18 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.9-1
- Update parking_lot to 0.8

* Mon Mar 04 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.9-1
- Update to 0.1.9

* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.8-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Tue Jan 08 2019 Josh Stone <jistone@redhat.com> - 0.1.8-1
- Update to 0.1.8

* Sat Dec 15 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.7-1
- Update to 0.1.7

* Fri Nov 09 2018 Josh Stone <jistone@redhat.com> - 0.1.6-3
- Enable checks

* Thu Nov 08 2018 Josh Stone <jistone@redhat.com> - 0.1.6-2
- Adapt to new packaging

* Thu Sep 27 2018 Josh Stone <jistone@redhat.com> - 0.1.6-1
- Initial package