Blob Blame History Raw
# Generated by rust2rpm
# Tests are run in infrastructure
%bcond_with check
%global debug_package %{nil}

%global crate tokio-fs

Name:           rust-%{crate}
Version:        0.1.2
Release:        4%{?dist}
Summary:        Filesystem API for Tokio

License:        MIT
URL:            https://crates.io/crates/tokio-fs
Source0:        https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
# [dependencies]
BuildRequires:  (crate(futures) >= 0.1.21 with crate(futures) < 0.2.0)
BuildRequires:  (crate(tokio-io) >= 0.1.6 with crate(tokio-io) < 0.2.0)
BuildRequires:  (crate(tokio-threadpool) >= 0.1.3 with crate(tokio-threadpool) < 0.2.0)
%if %{with check}
# [dev-dependencies]
BuildRequires:  (crate(rand) >= 0.4.2 with crate(rand) < 0.5.0)
BuildRequires:  (crate(tempdir) >= 0.3.7 with crate(tempdir) < 0.4.0)
BuildRequires:  (crate(tokio-codec) >= 0.1.0 with crate(tokio-codec) < 0.2.0)
BuildRequires:  (crate(tokio-io) >= 0.1.6 with crate(tokio-io) < 0.2.0)
%endif

%description
%{summary}.

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel
Filesystem API for Tokio.

This package contains library source intended for building other packages
which use %{crate} from crates.io.

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%files          devel
%license LICENSE
%doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version}/

%changelog
* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.2-4
- Rebuild to trigger tests

* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.2-3
- Rebuild to trigger tests

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Thu Jul 12 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.2-1
- Update to 0.1.2

* Tue Jun 19 2018 Josh Stone <jistone@redhat.com> - 0.1.1-1
- Update to 0.1.1

* Thu May 03 2018 Josh Stone <jistone@redhat.com> - 0.1.0-1
- Initial package