Blob Blame History Raw
# Generated by rust2rpm
# Tests are run in infrastructure
%bcond_with check
%global debug_package %{nil}

%global crate tokio-fs

Name:           rust-%{crate}
Version:        0.1.5
Release:        1%{?dist}
Summary:        Filesystem API for Tokio

License:        MIT
URL:            https://crates.io/crates/tokio-fs
Source0:        https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(futures/default) >= 0.1.21 with crate(futures/default) < 0.2.0)
BuildRequires:  (crate(tokio-io/default) >= 0.1.6 with crate(tokio-io/default) < 0.2.0)
BuildRequires:  (crate(tokio-threadpool/default) >= 0.1.3 with crate(tokio-threadpool/default) < 0.2.0)
%if %{with check}
BuildRequires:  (crate(rand/default) >= 0.6.0 with crate(rand/default) < 0.7.0)
BuildRequires:  (crate(tempdir/default) >= 0.3.0 with crate(tempdir/default) < 0.4.0)
BuildRequires:  (crate(tempfile/default) >= 3.0.0 with crate(tempfile/default) < 4.0.0)
BuildRequires:  (crate(tokio-codec/default) >= 0.1.0 with crate(tokio-codec/default) < 0.2.0)
BuildRequires:  (crate(tokio-io/default) >= 0.1.6 with crate(tokio-io/default) < 0.2.0)
BuildRequires:  (crate(tokio/default) >= 0.1.7 with crate(tokio/default) < 0.2.0)
%endif

%global _description \
Filesystem API for Tokio.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Tue Jan 08 2019 Josh Stone <jistone@redhat.com> - 0.1.5-1
- Update to 0.1.5

* Thu Nov 08 2018 Josh Stone <jistone@redhat.com> - 0.1.4-2
- Adapt to new packaging

* Thu Oct 25 2018 Josh Stone <jistone@redhat.com> - 0.1.4-1
- Update to 0.1.4

* Wed Aug 08 2018 Josh Stone <jistone@redhat.com> - 0.1.3-1
- Update to 0.1.3

* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.2-4
- Rebuild to trigger tests

* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.2-3
- Rebuild to trigger tests

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Thu Jul 12 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.2-1
- Update to 0.1.2

* Tue Jun 19 2018 Josh Stone <jistone@redhat.com> - 0.1.1-1
- Update to 0.1.1

* Thu May 03 2018 Josh Stone <jistone@redhat.com> - 0.1.0-1
- Initial package