Blob Blame History Raw
# Generated by rust2rpm
# * criterion is not packaged yet
%bcond_with check
%global debug_package %{nil}

%global crate syntect

Name:           rust-%{crate}
Version:        3.0.2
Release:        3%{?dist}
Summary:        Library for high quality syntax highlighting and code intelligence

License:        MIT
URL:            https://crates.io/crates/syntect
Source:         %{crates_source}
# Initial patched metadata
# * Bump plist to 0.4, https://github.com/trishume/syntect/pull/232
Patch0:         syntect-fix-metadata.diff
# Make it work with new plist
Patch1:         0001-Update-plist-to-v0.4.patch

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(bincode/default) >= 1.0.0 with crate(bincode/default) < 2.0.0)
BuildRequires:  (crate(bitflags/default) >= 1.0.0 with crate(bitflags/default) < 2.0.0)
BuildRequires:  (crate(flate2) >= 1.0.0 with crate(flate2) < 2.0.0)
BuildRequires:  (crate(flate2/default) >= 1.0.0 with crate(flate2/default) < 2.0.0)
BuildRequires:  (crate(flate2/rust_backend) >= 1.0.0 with crate(flate2/rust_backend) < 2.0.0)
BuildRequires:  (crate(fnv/default) >= 1.0.0 with crate(fnv/default) < 2.0.0)
BuildRequires:  (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires:  (crate(lazycell/default) >= 1.0.0 with crate(lazycell/default) < 2.0.0)
BuildRequires:  (crate(onig/default) >= 4.1.0 with crate(onig/default) < 5.0.0)
BuildRequires:  (crate(plist/default) >= 0.4.0 with crate(plist/default) < 0.5.0)
BuildRequires:  (crate(regex-syntax/default) >= 0.6.0 with crate(regex-syntax/default) < 0.7.0)
BuildRequires:  (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
BuildRequires:  (crate(serde_derive/default) >= 1.0.0 with crate(serde_derive/default) < 2.0.0)
BuildRequires:  (crate(serde_json/default) >= 1.0.0 with crate(serde_json/default) < 2.0.0)
BuildRequires:  (crate(walkdir/default) >= 2.0.0 with crate(walkdir/default) < 3.0.0)
BuildRequires:  (crate(yaml-rust/default) >= 0.4.0 with crate(yaml-rust/default) < 0.5.0)
%if %{with check}
BuildRequires:  (crate(criterion/default) >= 0.2.0 with crate(criterion/default) < 0.3.0)
BuildRequires:  (crate(getopts/default) >= 0.2.0 with crate(getopts/default) < 0.3.0)
BuildRequires:  (crate(pretty_assertions/default) >= 0.5.0 with crate(pretty_assertions/default) < 0.6.0)
BuildRequires:  (crate(rayon/default) >= 1.0.0 with crate(rayon/default) < 2.0.0)
BuildRequires:  (crate(regex/default) >= 1.0.0 with crate(regex/default) < 2.0.0)
%endif

%global _description \
Library for high quality syntax highlighting and code intelligence using\
Sublime Text's grammars.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE.txt
%doc Readme.md DESIGN.md
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+assets-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+assets-devel %{_description}

This package contains library source intended for building other packages
which use "assets" feature of "%{crate}" crate.

%files       -n %{name}+assets-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+bincode-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+bincode-devel %{_description}

This package contains library source intended for building other packages
which use "bincode" feature of "%{crate}" crate.

%files       -n %{name}+bincode-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+dump-create-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dump-create-devel %{_description}

This package contains library source intended for building other packages
which use "dump-create" feature of "%{crate}" crate.

%files       -n %{name}+dump-create-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+dump-create-rs-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dump-create-rs-devel %{_description}

This package contains library source intended for building other packages
which use "dump-create-rs" feature of "%{crate}" crate.

%files       -n %{name}+dump-create-rs-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+dump-load-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dump-load-devel %{_description}

This package contains library source intended for building other packages
which use "dump-load" feature of "%{crate}" crate.

%files       -n %{name}+dump-load-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+dump-load-rs-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dump-load-rs-devel %{_description}

This package contains library source intended for building other packages
which use "dump-load-rs" feature of "%{crate}" crate.

%files       -n %{name}+dump-load-rs-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+flate2-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+flate2-devel %{_description}

This package contains library source intended for building other packages
which use "flate2" feature of "%{crate}" crate.

%files       -n %{name}+flate2-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+fnv-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+fnv-devel %{_description}

This package contains library source intended for building other packages
which use "fnv" feature of "%{crate}" crate.

%files       -n %{name}+fnv-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+html-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+html-devel %{_description}

This package contains library source intended for building other packages
which use "html" feature of "%{crate}" crate.

%files       -n %{name}+html-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+onig-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+onig-devel %{_description}

This package contains library source intended for building other packages
which use "onig" feature of "%{crate}" crate.

%files       -n %{name}+onig-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+parsing-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+parsing-devel %{_description}

This package contains library source intended for building other packages
which use "parsing" feature of "%{crate}" crate.

%files       -n %{name}+parsing-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+regex-syntax-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+regex-syntax-devel %{_description}

This package contains library source intended for building other packages
which use "regex-syntax" feature of "%{crate}" crate.

%files       -n %{name}+regex-syntax-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+yaml-load-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+yaml-load-devel %{_description}

This package contains library source intended for building other packages
which use "yaml-load" feature of "%{crate}" crate.

%files       -n %{name}+yaml-load-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+yaml-rust-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+yaml-rust-devel %{_description}

This package contains library source intended for building other packages
which use "yaml-rust" feature of "%{crate}" crate.

%files       -n %{name}+yaml-rust-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Sun Feb 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.0.2-3
- Bump plist to 0.4

* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Tue Nov 13 2018 Josh Stone <jistone@redhat.com> - 3.0.2-1
- Update to 3.0.2

* Sun Nov 04 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.0.1-1
- Update to 3.0.1

* Mon Sep 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.1.0-1
- Initial package