Blob Blame History Raw
# Generated by rust2rpm
# * Tests require nightly compiler
%bcond_with check
%global debug_package %{nil}

%global crate syn

Name:           rust-%{crate}
Version:        0.15.14
Release:        1%{?dist}
Summary:        Parser for Rust source code

# Upstream license specification: MIT/Apache-2.0
License:        MIT or ASL 2.0
URL:            https://crates.io/crates/syn
Source0:        https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
# [dependencies]
BuildRequires:  (crate(proc-macro2) >= 0.4.4 with crate(proc-macro2) < 0.5.0)
BuildRequires:  (crate(quote) >= 0.6.0 with crate(quote) < 0.7.0)
BuildRequires:  (crate(unicode-xid) >= 0.1.0 with crate(unicode-xid) < 0.2.0)
%if %{with check}
# [dev-dependencies]
BuildRequires:  (crate(rayon) >= 1.0.0 with crate(rayon) < 2.0.0)
BuildRequires:  (crate(regex) >= 1.0.0 with crate(regex) < 2.0.0)
BuildRequires:  (crate(walkdir) >= 2.1.0 with crate(walkdir) < 3.0.0)
%endif

%description
%{summary}.

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel
Parser for Rust source code.

This package contains library source intended for building other packages
which use %{crate} from crates.io.

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%files          devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/

%changelog
* Fri Oct 26 2018 Josh Stone <jistone@redhat.com> - 0.15.14-1
- Update to 0.15.14

* Mon Oct 22 2018 Josh Stone <jistone@redhat.com> - 0.15.13-1
- Update to 0.15.13

* Mon Oct 15 2018 Josh Stone <jistone@redhat.com> - 0.15.11-1
- Update to 0.15.11

* Mon Oct 08 2018 Josh Stone <jistone@redhat.com> - 0.15.9-1
- Update to 0.15.9

* Wed Oct 03 2018 Josh Stone <jistone@redhat.com> - 0.15.8-1
- Update to 0.15.8

* Mon Oct 01 2018 Josh Stone <jistone@redhat.com> - 0.15.7-1
- Update to 0.15.7

* Fri Sep 28 2018 Josh Stone <jistone@redhat.com> - 0.15.6-1
- Update to 0.15.6

* Wed Sep 12 2018 Josh Stone <jistone@redhat.com> - 0.15.4-1
- Update to 0.15.4

* Tue Sep 11 2018 Josh Stone <jistone@redhat.com> - 0.15.3-1
- Update to 0.15.3

* Sat Sep 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.15.1-1
- Update to 0.15.1

* Mon Aug 13 2018 Josh Stone <jistone@redhat.com> - 0.14.8-1
- Update to 0.14.8

* Sat Aug 04 2018 Josh Stone <jistone@redhat.com> - 0.14.7-1
- Update to 0.14.7

* Thu Aug 02 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.14.6-1
- Update to 0.14.6

* Mon Jul 23 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.14.5-1
- Update to 0.14.5

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Sun Jul 01 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.14.4-1
- Update to 0.14.4

* Thu Jun 21 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.14.2-1
- Update to 0.14.2

* Sun May 20 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.13.11-1
- Update to 0.13.11

* Mon May 14 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.13.10-1
- Update to 0.13.10

* Sat May 12 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.13.9-1
- Update to 0.13.9

* Sat May 12 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.13.8-1
- Update to 0.13.8

* Sun May 06 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.13.7-1
- Update to 0.13.7

* Sat May 05 2018 Josh Stone <jistone@redhat.com> - 0.13.5-1
- Update to 0.13.5

* Wed May 02 2018 Josh Stone <jistone@redhat.com> - 0.13.4-1
- Update to 0.13.4

* Tue Apr 17 2018 Josh Stone <jistone@redhat.com> - 0.13.1-1
- Update to 0.13.1

* Wed Mar 28 2018 Josh Stone <jistone@redhat.com> - 0.12.15-1
- Update to 0.12.15

* Fri Mar 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.12.14-1
- Update to 0.12.14

* Thu Mar 08 2018 Josh Stone <jistone@redhat.com> - 0.12.13-1
- Update to 0.12.13

* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.11-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.11-2
- Rebuild for rust-packaging v5

* Thu Jun 15 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.11-1
- Update to 0.11.11

* Wed Jun 14 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.9-2
- Port to use rust-packaging

* Tue Mar 07 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.9-1
- Update to 0.11.9

* Tue Feb 28 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.8-1
- Update to 0.11.8

* Mon Feb 27 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.7-1
- Update to 0.11.7

* Fri Feb 24 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.6-1
- Update to 0.11.6

* Sat Feb 18 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.4-1
- Initial package