Blob Blame History Raw
# Generated by rust2rpm
%bcond_with check
%global debug_package %{nil}

%global crate string_cache

Name:           rust-%{crate}
Version:        0.7.3
Release:        1%{?dist}
Summary:        String interning library for Rust, developed as part of the Servo project

# Upstream license specification: MIT / Apache-2.0
License:        MIT or ASL 2.0
URL:            https://crates.io/crates/string_cache
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires:  (crate(new_debug_unreachable/default) >= 1.0.0 with crate(new_debug_unreachable/default) < 2.0.0)
BuildRequires:  (crate(phf_shared/default) >= 0.7.4 with crate(phf_shared/default) < 0.8.0)
BuildRequires:  (crate(precomputed-hash/default) >= 0.1.0 with crate(precomputed-hash/default) < 0.2.0)
BuildRequires:  (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
BuildRequires:  (crate(string_cache_codegen/default) >= 0.4.0 with crate(string_cache_codegen/default) < 0.5.0)
BuildRequires:  (crate(string_cache_shared/default) >= 0.3.0 with crate(string_cache_shared/default) < 0.4.0)
%if %{with check}
BuildRequires:  (crate(rand/default) >= 0.4.0 with crate(rand/default) < 0.5.0)
%endif

%global _description \
A string interning library for Rust, developed as part of the Servo project.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+log-events-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+log-events-devel %{_description}

This package contains library source intended for building other packages
which use "log-events" feature of "%{crate}" crate.

%files       -n %{name}+log-events-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+unstable-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unstable-devel %{_description}

This package contains library source intended for building other packages
which use "unstable" feature of "%{crate}" crate.

%files       -n %{name}+unstable-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Mon Mar 11 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.3-1
- Initial package