Blob Blame History Raw
# Generated by rust2rpm
# Upstream doesn't provide the necessary fonts in the crate for the test
# https://gitlab.redox-os.org/redox-os/stb_truetype-rs/issues/22
%bcond_with check
%global debug_package %{nil}

%global crate stb_truetype

Name:           rust-%{crate}
Version:        0.2.6
Release:        3%{?dist}
Summary:        Straight translation of the font loading code in stb_truetype.h from C to Rust

# Upstream license specification: MIT / Apache-2.0
License:        MIT or ASL 2.0
URL:            https://crates.io/crates/stb_truetype
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(byteorder/default) >= 1.1.0 with crate(byteorder/default) < 2.0.0)
%if %{with check}
BuildRequires:  (crate(approx) >= 0.3.0 with crate(approx) < 0.4.0)
%endif

%global _description \
A straight translation of the font loading code in stb_truetype.h from C to\
Rust.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%doc README.md CHANGELOG.md
%license LICENSE-APACHE LICENSE-MIT
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.6-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

* Wed Mar 20 09:50:53 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.6-2
- Run tests in infrastructure

* Sat Mar 16 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.2.6-1
- Initial package