Blob Blame History Raw
# Generated by rust2rpm 13
%bcond_without check
# No devel stuff in released Fedora
%global __cargo_is_lib() false

%global crate starship

Name:           rust-%{crate}
Version:        0.37.0
Release:        2%{?dist}
Summary:        Minimal, blazing-fast, and infinitely customizable prompt for any shell! ☄🌌️

# Upstream license specification: ISC
License:        ISC
URL:            https://crates.io/crates/starship
Source:         %{crates_source}
# Initial patched metadata
# * Use default features (OpenSSL) for reqwest, essentially revert of https://github.com/starship/starship/commit/d1b725a47cda1047546fb3998ff8f8a61ed4a48b
# * Update git2 to 0.13, https://github.com/starship/starship/commit/d5cf340a72bcb966cd68510f00742e5ba6111453
Patch0:         starship-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging

%global _description %{expand:
Minimal, blazing-fast, and infinitely customizable prompt for any shell! ☄🌌️.}

%description %{_description}

%package     -n %{crate}
Summary:        %{summary}
# Install all deps (without check), grab their licenses and make it simple
# * ASL 2.0
# * ASL 2.0 or Boost
# * ASL 2.0 or MIT
# * ISC
# * MIT
# * MIT or ASL 2.0
# * (MIT or ASL 2.0) and BSD
# * Unlicense or MIT
License:        ISC and ASL 2.0 and MIT and BSD

%description -n %{crate} %{_description}

%files       -n %{crate}
%license LICENSE
%doc README.md
%{_bindir}/starship

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
# https://github.com/starship/starship/issues/755
sed -i -e '/EXE_PATH/s|/debug/|/release/|' tests/testsuite/common.rs
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires
%if %{with check}
echo 'git-core'
%endif

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Thu Mar 19 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.37.0-2
- Update to 0.37.0

* Tue Feb 11 16:43:01 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.35.1-1
- Update to 0.35.1

* Thu Dec 26 11:55:11 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.32.1-1.1
- Initial package