Blob Blame History Raw
# Generated by rust2rpm-9-1.fc31
%bcond_with check
%global debug_package %{nil}

%global crate socket2

Name:           rust-%{crate}
Version:        0.3.9
Release:        1%{?dist}
Summary:        Utilities for handling networking sockets

# Upstream license specification: MIT/Apache-2.0
License:        MIT or ASL 2.0
URL:            https://crates.io/crates/socket2
Source:         %{crates_source}
# Initial patched metadata
# * No windows or redox
Patch0:         socket2-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(cfg-if/default) >= 0.1.0 with crate(cfg-if/default) < 0.2.0)
BuildRequires:  (crate(libc/default) >= 0.2.42 with crate(libc/default) < 0.3.0)
%if %{with check}
BuildRequires:  (crate(tempdir/default) >= 0.3.0 with crate(tempdir/default) < 0.4.0)
%endif

%global _description \
Utilities for handling networking sockets with a maximal amount of\
configuration possible intended.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+pair-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+pair-devel %{_description}

This package contains library source intended for building other packages
which use "pair" feature of "%{crate}" crate.

%files       -n %{name}+pair-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+reuseport-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+reuseport-devel %{_description}

This package contains library source intended for building other packages
which use "reuseport" feature of "%{crate}" crate.

%files       -n %{name}+reuseport-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+unix-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unix-devel %{_description}

This package contains library source intended for building other packages
which use "unix" feature of "%{crate}" crate.

%files       -n %{name}+unix-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Tue May 07 07:55:39 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.9-1
- Update to 0.3.9

* Tue Feb 12 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.8-4
- Run tests in infrastructure

* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.8-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Sat Nov 10 2018 Josh Stone <jistone@redhat.com> - 0.3.8-2
- Adapt to new packaging

* Sat Sep 08 2018 Josh Stone <jistone@redhat.com> - 0.3.8-1
- Update to 0.3.8

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.7-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Thu Jun 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.7-1
- Update to 0.3.7

* Tue Jun 05 2018 Josh Stone <jistone@redhat.com> - 0.3.6-1
- Update to 0.3.6

* Tue Apr 17 2018 Josh Stone <jistone@redhat.com> - 0.3.5-1
- Update to 0.3.5

* Wed Mar 14 2018 Josh Stone <jistone@redhat.com> - 0.3.4-1
- Update to 0.3.4

* Mon Mar 05 2018 Josh Stone <jistone@redhat.com> - 0.3.3-1
- Update to 0.3.3

* Thu Mar 01 2018 Josh Stone <jistone@redhat.com> - 0.3.2-1
- Update to 0.3.2

* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

* Wed Jan 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.1-1
- Update to 0.3.1

* Sat Jan 13 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.0-1
- Initial package