Blob Blame History Raw
# Generated by rust2rpm
%bcond_without check
%global debug_package %{nil}

%global crate resize

Name:           rust-%{crate}
Version:        0.3.0
Release:        1%{?dist}
Summary:        Simple resampling library in pure Rust

License:        MIT
URL:            https://crates.io/crates/resize
Source:         %{crates_source}
# Initial patched metadata
# - Bump png to 0.14 https://github.com/PistonDevelopers/resize/pull/24
Patch0:         resize-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
%if %{with check}
BuildRequires:  (crate(png/default) >= 0.14.0 with crate(png/default) < 0.15.0)
%endif

%global _description \
Simple resampling library in pure Rust.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%doc README.md
%license LICENSE
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Sat Mar 09 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.3.0-1
- Initial package