Blob Blame History Raw
# Generated by rust2rpm 17
%bcond_without check
%global debug_package %{nil}

%global crate ref-cast

Name:           rust-%{crate}
Version:        1.0.6
Release:        1%{?dist}
Summary:        Safely cast &T to &U where the struct U contains a single field of type T

# Upstream license specification: MIT OR Apache-2.0
License:        MIT or ASL 2.0
URL:            https://crates.io/crates/ref-cast
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
Safely cast &T to &U where the struct U contains a single field of type T.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Tue Dec 29 22:12:24 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.0.6-1
- Update to 1.0.6 (Fixes: RHBZ#1911514)

* Sun Dec 27 08:54:56 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.0.5-1
- Update to 1.0.5

* Thu Nov 12 2020 Fabio Valentini <decathorpe@gmail.com> - 1.0.3-1
- Update to version 1.0.3.
- Fixes RHBZ#1892516

* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

* Fri Jun 19 2020 Josh Stone <jistone@redhat.com> - 1.0.2-1
- Update to 1.0.2

* Mon Mar 23 19:32:42 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.0.1-1
- Update to 1.0.1

* Mon Mar 23 18:53:43 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 1.0.0-1
- Initial package