Blob Blame History Raw
# Generated by rust2rpm 15
%bcond_without check
%global debug_package %{nil}

%global crate path-dedot

Name:           rust-%{crate}
Version:        1.2.2
Release:        1%{?dist}
Summary:        Parse path with dots in `Path` and `PathBuf`

# Upstream license specification: MIT
License:        MIT
URL:            https://crates.io/crates/path-dedot
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
Library for extending `Path` and `PathBuf` in order to parse the path which
contains dots.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
# https://github.com/magiclen/path-dedot/issues/3
%cargo_test -- -- --test-threads=1
%endif

%changelog
* Mon May 25 19:45:58 CEST 2020 Igor Raits <i.gnatenko.brain@gmail.com> - 1.2.2-1
- Initial package