Blob Blame History Raw
# Generated by rust2rpm
%bcond_with check
%global debug_package %{nil}

%global crate pango

Name:           rust-%{crate}
Version:        0.5.0
Release:        1%{?dist}
Summary:        Rust bindings for the Pango library

License:        MIT
URL:            https://crates.io/crates/pango
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(bitflags/default) >= 1.0.0 with crate(bitflags/default) < 2.0.0)
BuildRequires:  (crate(glib-sys/default) >= 0.7.0 with crate(glib-sys/default) < 0.8.0)
BuildRequires:  (crate(glib/default) >= 0.6.0 with crate(glib/default) < 0.7.0)
BuildRequires:  (crate(glib/dox) >= 0.6.0 with crate(glib/dox) < 0.7.0)
BuildRequires:  (crate(gobject-sys/default) >= 0.7.0 with crate(gobject-sys/default) < 0.8.0)
BuildRequires:  (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires:  (crate(libc/default) >= 0.2.0 with crate(libc/default) < 0.3.0)
BuildRequires:  (crate(pango-sys/default) >= 0.7.0 with crate(pango-sys/default) < 0.8.0)
BuildRequires:  (crate(pango-sys/dox) >= 0.7.0 with crate(pango-sys/dox) < 0.8.0)
BuildRequires:  (crate(pango-sys/v1_31) >= 0.7.0 with crate(pango-sys/v1_31) < 0.8.0)
BuildRequires:  (crate(pango-sys/v1_32) >= 0.7.0 with crate(pango-sys/v1_32) < 0.8.0)
BuildRequires:  (crate(pango-sys/v1_32_4) >= 0.7.0 with crate(pango-sys/v1_32_4) < 0.8.0)
BuildRequires:  (crate(pango-sys/v1_34) >= 0.7.0 with crate(pango-sys/v1_34) < 0.8.0)
BuildRequires:  (crate(pango-sys/v1_36_7) >= 0.7.0 with crate(pango-sys/v1_36_7) < 0.8.0)
BuildRequires:  (crate(pango-sys/v1_38) >= 0.7.0 with crate(pango-sys/v1_38) < 0.8.0)
BuildRequires:  (crate(pango-sys/v1_42) >= 0.7.0 with crate(pango-sys/v1_42) < 0.8.0)
%if %{with check}
BuildRequires:  (crate(gir-format-check/default) >= 0.1.0 with crate(gir-format-check/default) < 0.2.0)
%endif

%global _description \
Rust bindings for the Pango library.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license COPYRIGHT LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{appveyor.yml,LGPL,Makefile}

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+dox-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dox-devel %{_description}

This package contains library source intended for building other packages
which use "dox" feature of "%{crate}" crate.

%files       -n %{name}+dox-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_31-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_31-devel %{_description}

This package contains library source intended for building other packages
which use "v1_31" feature of "%{crate}" crate.

%files       -n %{name}+v1_31-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_32-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_32-devel %{_description}

This package contains library source intended for building other packages
which use "v1_32" feature of "%{crate}" crate.

%files       -n %{name}+v1_32-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_32_4-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_32_4-devel %{_description}

This package contains library source intended for building other packages
which use "v1_32_4" feature of "%{crate}" crate.

%files       -n %{name}+v1_32_4-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_34-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_34-devel %{_description}

This package contains library source intended for building other packages
which use "v1_34" feature of "%{crate}" crate.

%files       -n %{name}+v1_34-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_36_7-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_36_7-devel %{_description}

This package contains library source intended for building other packages
which use "v1_36_7" feature of "%{crate}" crate.

%files       -n %{name}+v1_36_7-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_38-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_38-devel %{_description}

This package contains library source intended for building other packages
which use "v1_38" feature of "%{crate}" crate.

%files       -n %{name}+v1_38-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_40-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_40-devel %{_description}

This package contains library source intended for building other packages
which use "v1_40" feature of "%{crate}" crate.

%files       -n %{name}+v1_40-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_42-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_42-devel %{_description}

This package contains library source intended for building other packages
which use "v1_42" feature of "%{crate}" crate.

%files       -n %{name}+v1_42-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Mon Feb 18 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-1
- Update to 0.5.0

* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Thu Mar 22 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.0-1
- Update to 0.4.0

* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.0-2
- Rebuild for rust-packaging v5

* Sat Jan 06 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.0-1
- Initial package