Blob Blame History Raw
# Generated by rust2rpm 13
%bcond_without check
%global debug_package %{nil}

%global crate os_info

Name:           rust-%{crate}
Version:        1.3.1
Release:        1%{?dist}
Summary:        Detect the operating system type and version

# Upstream license specification: MIT
License:        MIT
URL:            https://crates.io/crates/os_info
Source:         %{crates_source}
# Initial patched metadata
# * Remove Windows/MacOS only deps
Patch0:         os_info-fix-metadata.diff

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
Detect the operating system type and version.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%doc README.md CONTRIBUTING.md Changelog.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Wed Jan 15 13:10:27 EET 2020 Artem Polishchuk <ego.cordatus@gmail.com> - 1.3.1-1
- Update to 1.3.1

* Wed Jan 15 2020 Josh Stone <jistone@redhat.com> - 1.3.0-1
- Update to 1.3.0

* Sat Dec 21 01:56:19 EET 2019 Artem Polishchuk <ego.cordatus@gmail.com> - 1.2.0-1
- Initial package