Blob Blame History Raw
# Generated by rust2rpm
# Tests are run in infrastructure
%bcond_with check
%global debug_package %{nil}

%global crate native-tls

Name:           rust-%{crate}
Version:        0.2.1
Release:        1%{?dist}
Summary:        Wrapper over a platform's native TLS implementation

License:        MIT or ASL 2.0
URL:            https://crates.io/crates/native-tls
Source0:        https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * No windows/macos/ios
# * No "vendored" feature
Patch0:         native-tls-0.2.1-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
# [dependencies]
BuildRequires:  (crate(openssl) >= 0.10.11 with crate(openssl) < 0.11.0)
BuildRequires:  (crate(openssl-probe) >= 0.1.0 with crate(openssl-probe) < 0.2.0)
BuildRequires:  (crate(openssl-sys) >= 0.9.30 with crate(openssl-sys) < 0.10.0)
%if %{with check}
# [dev-dependencies]
BuildRequires:  (crate(hex) >= 0.3.0 with crate(hex) < 0.4.0)
%endif

%description
%{summary}.

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel
A wrapper over a platform's native TLS implementation.

This package contains library source intended for building other packages
which use %{crate} from crates.io.

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%files          devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml

%changelog
* Tue Aug 07 2018 Josh Stone <jistone@redhat.com> - 0.2.1-1
- Update to 0.2.1

* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.0-3
- Rebuild to trigger tests

* Sat Jul 21 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.0-2
- Run tests in infrastructure

* Sun Jul 15 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.0-1
- Initial package