Blob Blame History Raw
# Generated by rust2rpm
# Doctests require networking
%bcond_without check
%global debug_package %{nil}

%global crate mio

Name:           rust-%{crate}
Version:        0.6.16
Release:        2%{?dist}
Summary:        Lightweight non-blocking IO

License:        MIT
URL:            https://crates.io/crates/mio
Source0:        https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * No windows or fuchsia
Patch0:         mio-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
# [dependencies]
BuildRequires:  (crate(iovec) >= 0.1.1 with crate(iovec) < 0.2.0)
BuildRequires:  (crate(lazycell) >= 1.0.0 with crate(lazycell) < 2.0.0)
BuildRequires:  (crate(libc) >= 0.2.42 with crate(libc) < 0.3.0)
BuildRequires:  (crate(log) >= 0.4.0 with crate(log) < 0.5.0)
BuildRequires:  (crate(net2) >= 0.2.29 with crate(net2) < 0.3.0)
BuildRequires:  (crate(slab) >= 0.4.0 with crate(slab) < 0.5.0)
%if %{with check}
# [dev-dependencies]
BuildRequires:  (crate(bytes) >= 0.3.0 with crate(bytes) < 0.4.0)
BuildRequires:  (crate(env_logger) >= 0.4.0 with crate(env_logger) < 0.5.0)
BuildRequires:  (crate(tempdir) >= 0.3.4 with crate(tempdir) < 0.4.0)
%endif

%description
%{summary}.

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel
Lightweight non-blocking IO.

This package contains library source intended for building other packages
which use %{crate} from crates.io.

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%files          devel
%license LICENSE
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{appveyor.yml,ci}

%changelog
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.16-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Sat Sep 08 2018 Josh Stone <jistone@redhat.com> - 0.6.16-1
- Update to 0.6.16

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.15-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Wed Jul 11 2018 Josh Stone <jistone@redhat.com> - 0.6.15-1
- Update to 0.6.15

* Fri Jun 15 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.14-2
- Bump lazycell to 1

* Fri Mar 09 2018 Josh Stone <jistone@redhat.com> - 0.6.14-1
- Update to 0.6.14

* Wed Feb 07 2018 Josh Stone <jistone@redhat.com> - 0.6.13-1
- Update to 0.6.13

* Wed Jan 10 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.12-1
- Update to 0.6.12

* Fri Dec 01 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.11-1
- Update to 0.6.11

* Fri Jun 16 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.6.9-1
- Initial package