Blob Blame History Raw
# Generated by rust2rpm
# * Tests are run in infrastructure
%bcond_with check
%global debug_package %{nil}

%global crate lock_api

Name:           rust-%{crate}
Version:        0.1.4
Release:        3%{?dist}
Summary:        Wrappers to create fully-featured Mutex and RwLock types

# Upstream license specification: Apache-2.0/MIT
License:        ASL 2.0 or MIT
URL:            https://crates.io/crates/lock_api
Source0:        https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Bump owning_ref to 0.4, https://github.com/Amanieu/parking_lot/pull/99
Patch0:         lock_api-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(owning_ref/default) >= 0.4.0 with crate(owning_ref/default) < 0.5.0)
BuildRequires:  (crate(scopeguard) >= 0.3.0 with crate(scopeguard) < 0.4.0)

%global _description \
Wrappers to create fully-featured Mutex and RwLock types.\
Compatible with no_std.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE-APACHE LICENSE-MIT
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+owning_ref-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+owning_ref-devel %{_description}

This package contains library source intended for building other packages
which use "owning_ref" feature of "%{crate}" crate.

%files       -n %{name}+owning_ref-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Sat Oct 27 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.4-3
- Adapt to new packaging

* Sun Oct 07 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.4-2
- Run tests in infrastructure

* Fri Sep 28 2018 Josh Stone <jistone@redhat.com> - 0.1.4-1
- Update to 0.1.4

* Mon Sep 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.3-1
- Initial package