Blob Blame History Raw
# Generated by rust2rpm
# * Tests are run in infrastructure
%bcond_with check
%global debug_package %{nil}

%global crate hyper

Name:           rust-%{crate}
Version:        0.12.22
Release:        1%{?dist}
Summary:        Fast and correct HTTP library

License:        MIT
URL:            https://crates.io/crates/hyper
Source0:        https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * Remove internal and nightly features
Patch0:         hyper-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(bytes/default) >= 0.4.4 with crate(bytes/default) < 0.5.0)
BuildRequires:  (crate(futures-cpupool/default) >= 0.1.6 with crate(futures-cpupool/default) < 0.2.0)
BuildRequires:  (crate(futures/default) >= 0.1.21 with crate(futures/default) < 0.2.0)
BuildRequires:  (crate(h2/default) >= 0.1.15 with crate(h2/default) < 0.2.0)
BuildRequires:  (crate(http/default) >= 0.1.15 with crate(http/default) < 0.2.0)
BuildRequires:  (crate(httparse/default) >= 1.0.0 with crate(httparse/default) < 2.0.0)
BuildRequires:  (crate(iovec/default) >= 0.1.0 with crate(iovec/default) < 0.2.0)
BuildRequires:  (crate(itoa/default) >= 0.4.1 with crate(itoa/default) < 0.5.0)
BuildRequires:  (crate(log/default) >= 0.4.0 with crate(log/default) < 0.5.0)
BuildRequires:  (crate(net2/default) >= 0.2.32 with crate(net2/default) < 0.3.0)
BuildRequires:  (crate(time/default) >= 0.1.0 with crate(time/default) < 0.2.0)
BuildRequires:  (crate(tokio-executor/default) >= 0.1.0 with crate(tokio-executor/default) < 0.2.0)
BuildRequires:  (crate(tokio-io/default) >= 0.1.0 with crate(tokio-io/default) < 0.2.0)
BuildRequires:  (crate(tokio-reactor/default) >= 0.1.0 with crate(tokio-reactor/default) < 0.2.0)
BuildRequires:  (crate(tokio-tcp/default) >= 0.1.0 with crate(tokio-tcp/default) < 0.2.0)
BuildRequires:  (crate(tokio-threadpool/default) >= 0.1.3 with crate(tokio-threadpool/default) < 0.2.0)
BuildRequires:  (crate(tokio-timer/default) >= 0.2.0 with crate(tokio-timer/default) < 0.3.0)
BuildRequires:  (crate(tokio/rt-full) >= 0.1.14 with crate(tokio/rt-full) < 0.2.0)
BuildRequires:  (crate(want/default) >= 0.0.6 with crate(want/default) < 0.0.7)
%if %{with check}
BuildRequires:  (crate(futures-timer/default) >= 0.1.0 with crate(futures-timer/default) < 0.2.0)
BuildRequires:  (crate(num_cpus/default) >= 1.0.0 with crate(num_cpus/default) < 2.0.0)
BuildRequires:  (crate(pretty_env_logger/default) >= 0.2.0 with crate(pretty_env_logger/default) < 0.3.0)
BuildRequires:  (crate(serde/default) >= 1.0.0 with crate(serde/default) < 2.0.0)
BuildRequires:  (crate(serde_derive/default) >= 1.0.0 with crate(serde_derive/default) < 2.0.0)
BuildRequires:  (crate(serde_json/default) >= 1.0.0 with crate(serde_json/default) < 2.0.0)
BuildRequires:  (crate(spmc/default) >= 0.2.0 with crate(spmc/default) < 0.3.0)
BuildRequires:  (crate(tokio-fs/default) >= 0.1.0 with crate(tokio-fs/default) < 0.2.0)
BuildRequires:  (crate(tokio-mockstream/default) >= 1.1.0 with crate(tokio-mockstream/default) < 2.0.0)
BuildRequires:  (crate(url/default) >= 1.0.0 with crate(url/default) < 2.0.0)
%endif

%global _description \
A fast and correct HTTP library.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+futures-cpupool-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+futures-cpupool-devel %{_description}

This package contains library source intended for building other packages
which use "futures-cpupool" feature of "%{crate}" crate.

%files       -n %{name}+futures-cpupool-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+net2-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+net2-devel %{_description}

This package contains library source intended for building other packages
which use "net2" feature of "%{crate}" crate.

%files       -n %{name}+net2-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+runtime-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+runtime-devel %{_description}

This package contains library source intended for building other packages
which use "runtime" feature of "%{crate}" crate.

%files       -n %{name}+runtime-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+tokio-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tokio-devel %{_description}

This package contains library source intended for building other packages
which use "tokio" feature of "%{crate}" crate.

%files       -n %{name}+tokio-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+tokio-executor-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tokio-executor-devel %{_description}

This package contains library source intended for building other packages
which use "tokio-executor" feature of "%{crate}" crate.

%files       -n %{name}+tokio-executor-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+tokio-reactor-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tokio-reactor-devel %{_description}

This package contains library source intended for building other packages
which use "tokio-reactor" feature of "%{crate}" crate.

%files       -n %{name}+tokio-reactor-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+tokio-tcp-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tokio-tcp-devel %{_description}

This package contains library source intended for building other packages
which use "tokio-tcp" feature of "%{crate}" crate.

%files       -n %{name}+tokio-tcp-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+tokio-threadpool-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tokio-threadpool-devel %{_description}

This package contains library source intended for building other packages
which use "tokio-threadpool" feature of "%{crate}" crate.

%files       -n %{name}+tokio-threadpool-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+tokio-timer-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tokio-timer-devel %{_description}

This package contains library source intended for building other packages
which use "tokio-timer" feature of "%{crate}" crate.

%files       -n %{name}+tokio-timer-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
# Test files are missing
%cargo_test -- --doc
%endif

%changelog
* Wed Jan 23 2019 Josh Stone <jistone@redhat.com> - 0.12.22-1
- Update to 0.12.22

* Tue Jan 15 2019 Josh Stone <jistone@redhat.com> - 0.12.21-1
- Update to 0.12.21

* Tue Jan 08 2019 Josh Stone <jistone@redhat.com> - 0.12.20-1
- Update to 0.12.20

* Wed Dec 12 2018 Josh Stone <jistone@redhat.com> - 0.12.18-1
- Update to 0.12.18

* Thu Dec 06 2018 Josh Stone <jistone@redhat.com> - 0.12.17-1
- Update to 0.12.17

* Mon Nov 26 2018 Josh Stone <jistone@redhat.com> - 0.12.16-1
- Update to 0.12.16

* Sun Nov 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.12.14-1
- Update to 0.12.14

* Mon Oct 22 2018 Josh Stone <jistone@redhat.com> - 0.12.12-1
- Update to 0.12.12

* Fri Sep 28 2018 Josh Stone <jistone@redhat.com> - 0.12.11-1
- Update to 0.12.11

* Mon Sep 17 2018 Josh Stone <jistone@redhat.com> - 0.12.10-1
- Update to 0.12.10

* Sat Sep 08 2018 Josh Stone <jistone@redhat.com> - 0.12.9-1
- Update to 0.12.9

* Sat Aug 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.12.8-1
- Update to 0.12.8

* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.12.7-2
- Rebuild to trigger tests

* Tue Jul 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.12.7-1
- Update to 0.12.7

* Fri Jul 13 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.12.6-1
- Update to 0.12.6

* Wed Jul 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.12.5-1
- Update to 0.12.5

* Sun May 06 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.26-1
- Update to 0.11.26

* Thu Apr 05 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.25-1
- Update to 0.11.25

* Fri Mar 23 2018 Josh Stone <jistone@redhat.com> - 0.11.24-1
- Update to 0.11.24

* Thu Mar 22 2018 Josh Stone <jistone@redhat.com> - 0.11.23-1
- Update to 0.11.23

* Fri Mar 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.11.22-1
- Initial package