Blob Blame History Raw
# Generated by rust2rpm 16
%bcond_with check
%global debug_package %{nil}

%global crate gstreamer

Name:           rust-%{crate}
Version:        0.16.5
Release:        1%{?dist}
Summary:        Rust bindings for GStreamer

# Upstream license specification: MIT/Apache-2.0
License:        MIT or ASL 2.0
URL:            https://crates.io/crates/gstreamer
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
Rust bindings for GStreamer.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+dox-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dox-devel %{_description}

This package contains library source intended for building other packages
which use "dox" feature of "%{crate}" crate.

%files       -n %{name}+dox-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+ser_de-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+ser_de-devel %{_description}

This package contains library source intended for building other packages
which use "ser_de" feature of "%{crate}" crate.

%files       -n %{name}+ser_de-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+serde-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde-devel %{_description}

This package contains library source intended for building other packages
which use "serde" feature of "%{crate}" crate.

%files       -n %{name}+serde-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+serde_bytes-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde_bytes-devel %{_description}

This package contains library source intended for building other packages
which use "serde_bytes" feature of "%{crate}" crate.

%files       -n %{name}+serde_bytes-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+serde_derive-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde_derive-devel %{_description}

This package contains library source intended for building other packages
which use "serde_derive" feature of "%{crate}" crate.

%files       -n %{name}+serde_derive-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+v1_10-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_10-devel %{_description}

This package contains library source intended for building other packages
which use "v1_10" feature of "%{crate}" crate.

%files       -n %{name}+v1_10-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+v1_12-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_12-devel %{_description}

This package contains library source intended for building other packages
which use "v1_12" feature of "%{crate}" crate.

%files       -n %{name}+v1_12-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+v1_14-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_14-devel %{_description}

This package contains library source intended for building other packages
which use "v1_14" feature of "%{crate}" crate.

%files       -n %{name}+v1_14-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+v1_16-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_16-devel %{_description}

This package contains library source intended for building other packages
which use "v1_16" feature of "%{crate}" crate.

%files       -n %{name}+v1_16-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%package     -n %{name}+v1_18-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_18-devel %{_description}

This package contains library source intended for building other packages
which use "v1_18" feature of "%{crate}" crate.

%files       -n %{name}+v1_18-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Wed Nov 25 2020 Fabio Valentini <decathorpe@gmail.com> - 0.16.5-1
- Update to version 0.16.5.
- Remove features with broken dependencies.
- Fixes RHBZ#1900586

* Sun Oct 11 2020 Fabio Valentini <decathorpe@gmail.com> - 0.16.4-1
- Update to version 0.16.4.

* Wed Sep 09 2020 Josh Stone <jistone@redhat.com> - 0.16.3-1
- Update to 0.16.3

* Wed Aug 26 2020 Josh Stone <jistone@redhat.com> - 0.16.2-2
- Bump to paste 1.0

* Wed Jul 29 2020 Josh Stone <jistone@redhat.com> - 0.16.2-1
- Update to 0.16.2

* Fri Jul 10 2020 Josh Stone <jistone@redhat.com> - 0.16.1-1
- Update to 0.16.1

* Thu Jul 09 2020 Josh Stone <jistone@redhat.com> - 0.15.7-2
- Bump num-rational to 0.3

* Wed Jun 10 2020 Josh Stone <jistone@redhat.com> - 0.15.7-1
- Update to 0.15.7

* Sat May 30 2020 Josh Stone <jistone@redhat.com> - 0.15.6-1
- Update to 0.15.6

* Tue May 05 2020 Josh Stone <cuviper@gmail.com> - 0.15.5-1
- Update to 0.15.5

* Tue Mar 10 2020 Josh Stone <jistone@redhat.com> - 0.15.4-1
- Update to 0.15.4

* Thu Feb 20 2020 Josh Stone <jistone@redhat.com> - 0.15.3-1
- Update to 0.15.3

* Thu Jan 30 2020 Josh Stone <jistone@redhat.com> - 0.15.2-1
- Update to 0.15.2

* Thu Jan 23 2020 Josh Stone <jistone@redhat.com> - 0.15.1-1
- Update to 0.15.1

* Thu Jan 16 2020 Josh Stone <jistone@redhat.com> - 0.15.0-1
- Update to 0.15.0

* Tue Dec 10 2019 Josh Stone <jistone@redhat.com> - 0.14.5-1
- Update to 0.14.5

* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.13.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

* Wed May 15 10:19:08 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.13.0-2
- Update serde_bytes to 0.11

* Sun May 05 15:46:49 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.13.0-1
- Initial package