Blob Blame History Raw
# Generated by rust2rpm
%bcond_without check
%global debug_package %{nil}

%global crate gstreamer-video

Name:           rust-%{crate}
Version:        0.13.0
Release:        1%{?dist}
Summary:        GStreamer (Video library) bindings for Rust

# Upstream license specification: MIT/Apache-2.0
License:        MIT or ASL 2.0
URL:            https://crates.io/crates/gstreamer-video
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(bitflags/default) >= 1.0.0 with crate(bitflags/default) < 2.0.0)
BuildRequires:  (crate(glib-sys/default) >= 0.8.0 with crate(glib-sys/default) < 0.9.0)
BuildRequires:  (crate(glib/default) >= 0.7.0 with crate(glib/default) < 0.8.0)
BuildRequires:  (crate(gobject-sys/default) >= 0.8.0 with crate(gobject-sys/default) < 0.9.0)
BuildRequires:  (crate(gstreamer-base-sys/default) >= 0.7.0 with crate(gstreamer-base-sys/default) < 0.8.0)
BuildRequires:  (crate(gstreamer-base-sys/v1_8) >= 0.7.0 with crate(gstreamer-base-sys/v1_8) < 0.8.0)
BuildRequires:  (crate(gstreamer-base/default) >= 0.13.0 with crate(gstreamer-base/default) < 0.14.0)
BuildRequires:  (crate(gstreamer-sys/default) >= 0.7.0 with crate(gstreamer-sys/default) < 0.8.0)
BuildRequires:  (crate(gstreamer-sys/v1_8) >= 0.7.0 with crate(gstreamer-sys/v1_8) < 0.8.0)
BuildRequires:  (crate(gstreamer-video-sys/default) >= 0.7.0 with crate(gstreamer-video-sys/default) < 0.8.0)
BuildRequires:  (crate(gstreamer-video-sys/v1_8) >= 0.7.0 with crate(gstreamer-video-sys/v1_8) < 0.8.0)
BuildRequires:  (crate(gstreamer/default) >= 0.13.0 with crate(gstreamer/default) < 0.14.0)
BuildRequires:  (crate(libc/default) >= 0.2.0 with crate(libc/default) < 0.3.0)

%global _description \
These bindings are providing a safe API that can be used to interface with\
GStreamer, e.g. for writing GStreamer-based applications and GStreamer plugins.\
\
The bindings are mostly autogenerated with gir\
based on the GObject-Introspection\
API metadata provided by the GStreamer project.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%doc README.md
%licence LICENSE-APACHE LICENSE-MIT
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+dox-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dox-devel %{_description}

This package contains library source intended for building other packages
which use "dox" feature of "%{crate}" crate.

%files       -n %{name}+dox-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+embed-lgpl-docs-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+embed-lgpl-docs-devel %{_description}

This package contains library source intended for building other packages
which use "embed-lgpl-docs" feature of "%{crate}" crate.

%files       -n %{name}+embed-lgpl-docs-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+purge-lgpl-docs-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+purge-lgpl-docs-devel %{_description}

This package contains library source intended for building other packages
which use "purge-lgpl-docs" feature of "%{crate}" crate.

%files       -n %{name}+purge-lgpl-docs-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+rustdoc-stripper-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+rustdoc-stripper-devel %{_description}

This package contains library source intended for building other packages
which use "rustdoc-stripper" feature of "%{crate}" crate.

%files       -n %{name}+rustdoc-stripper-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_10-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_10-devel %{_description}

This package contains library source intended for building other packages
which use "v1_10" feature of "%{crate}" crate.

%files       -n %{name}+v1_10-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_12-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_12-devel %{_description}

This package contains library source intended for building other packages
which use "v1_12" feature of "%{crate}" crate.

%files       -n %{name}+v1_12-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_14-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+v1_14-devel %{_description}

This package contains library source intended for building other packages
which use "v1_14" feature of "%{crate}" crate.

%files       -n %{name}+v1_14-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Sun May 05 18:52:49 EEST 2019 Artem Polishchuk <ego.cordatus@gmail.com> - 0.13.0-1
- Initial package