Blob Blame History Raw
# Generated by rust2rpm
%bcond_without check
%global debug_package %{nil}

%global crate gstreamer-audio-sys

Name:           rust-%{crate}
Version:        0.7.0
Release:        1%{?dist}
Summary:        GStreamer (Audio library) FFI bindings for Rust

# Upstream license specification: MIT
License:        MIT
URL:            https://crates.io/crates/gstreamer-audio-sys
Source:         %{crates_source}

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(glib-sys/default) >= 0.8.0 with crate(glib-sys/default) < 0.9.0)
BuildRequires:  (crate(gobject-sys/default) >= 0.8.0 with crate(gobject-sys/default) < 0.9.0)
BuildRequires:  (crate(gstreamer-base-sys/default) >= 0.7.0 with crate(gstreamer-base-sys/default) < 0.8.0)
BuildRequires:  (crate(gstreamer-sys/default) >= 0.7.0 with crate(gstreamer-sys/default) < 0.8.0)
BuildRequires:  (crate(libc/default) >= 0.2.0 with crate(libc/default) < 0.3.0)
BuildRequires:  (crate(pkg-config/default) >= 0.3.7 with crate(pkg-config/default) < 0.4.0)
%if %{with check}
BuildRequires:  (crate(shell-words/default) >= 0.1.0 with crate(shell-words/default) < 0.2.0)
BuildRequires:  (crate(tempdir/default) >= 0.3.0 with crate(tempdir/default) < 0.4.0)
%endif
BuildRequires:  pkgconfig(gstreamer-audio-1.0) >= 1.0

%global _description \
These bindings are providing unsafe FFI API that can be used to interface with\
GStreamer. Generally they are meant to be used as the building block for\
higher-level abstractions like:\
\
• Bindings for GStreamer applications and plugins:\
https://gitlab.freedesktop.org/gstreamer/gstreamer-rs\
\
• Various GStreamer plugins written in Rust:\
https://gitlab.freedesktop.org/gstreamer/gst-plugins-rs\
\
The bindings are autogenerated with gir based on the GObject-Introspection API\
metadata provided by the GStreamer project.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(gstreamer-audio-1.0) >= 1.0

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%doc README.md
%license LICENSE
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+dox-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dox-devel %{_description}

This package contains library source intended for building other packages
which use "dox" feature of "%{crate}" crate.

%files       -n %{name}+dox-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_10-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(gstreamer-audio-1.0) >= 1.10

%description -n %{name}+v1_10-devel %{_description}

This package contains library source intended for building other packages
which use "v1_10" feature of "%{crate}" crate.

%files       -n %{name}+v1_10-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_12-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(gstreamer-audio-1.0) >= 1.12

%description -n %{name}+v1_12-devel %{_description}

This package contains library source intended for building other packages
which use "v1_12" feature of "%{crate}" crate.

%files       -n %{name}+v1_12-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_14-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(gstreamer-audio-1.0) >= 1.14

%description -n %{name}+v1_14-devel %{_description}

This package contains library source intended for building other packages
which use "v1_14" feature of "%{crate}" crate.

%files       -n %{name}+v1_14-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_2-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(gstreamer-audio-1.0) >= 1.2

%description -n %{name}+v1_2-devel %{_description}

This package contains library source intended for building other packages
which use "v1_2" feature of "%{crate}" crate.

%files       -n %{name}+v1_2-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_4-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(gstreamer-audio-1.0) >= 1.4

%description -n %{name}+v1_4-devel %{_description}

This package contains library source intended for building other packages
which use "v1_4" feature of "%{crate}" crate.

%files       -n %{name}+v1_4-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_6-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(gstreamer-audio-1.0) >= 1.6

%description -n %{name}+v1_6-devel %{_description}

This package contains library source intended for building other packages
which use "v1_6" feature of "%{crate}" crate.

%files       -n %{name}+v1_6-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+v1_8-devel
Summary:        %{summary}
BuildArch:      noarch
Requires:       pkgconfig(gstreamer-audio-1.0) >= 1.8

%description -n %{name}+v1_8-devel %{_description}

This package contains library source intended for building other packages
which use "v1_8" feature of "%{crate}" crate.

%files       -n %{name}+v1_8-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Sun May 05 19:47:40 EEST 2019 Artem Polishchuk <ego.cordatus@gmail.com> - 0.7.0-1
- Initial package