Blob Blame History Raw
# Generated by rust2rpm
%bcond_without check

%global crate gcsf

Name:           rust-%{crate}
Version:        0.1.16
Release:        1%{?dist}
Summary:        Filesystem based on Google Drive

License:        MIT
URL:            https://crates.io/crates/gcsf
Source0:        https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
# [dependencies]
BuildRequires:  (crate(chrono) >= 0.4.3 with crate(chrono) < 0.5.0)
BuildRequires:  ((crate(clap) >= 2.31.2 with crate(clap) < 3.0.0) with crate(clap/yaml))
BuildRequires:  (crate(config) >= 0.9.0 with crate(config) < 0.10.0)
BuildRequires:  (crate(ctrlc) >= 3.1.0 with crate(ctrlc) < 4.0.0)
BuildRequires:  (crate(failure) >= 0.1.1 with crate(failure) < 0.2.0)
BuildRequires:  (crate(fuse) >= 0.3.1 with crate(fuse) < 0.4.0)
BuildRequires:  (crate(google-drive3-fork) >= 1.0.10 with crate(google-drive3-fork) < 2.0.0)
BuildRequires:  (crate(hyper) >= 0.10.0 with crate(hyper) < 0.11.0)
BuildRequires:  (crate(hyper-native-tls) >= 0.2.0 with crate(hyper-native-tls) < 0.3.0)
BuildRequires:  (crate(id_tree) >= 1.2.0 with crate(id_tree) < 2.0.0)
BuildRequires:  (crate(itertools) >= 0.7.8 with crate(itertools) < 0.8.0)
BuildRequires:  (crate(lazy_static) >= 1.0.0 with crate(lazy_static) < 2.0.0)
BuildRequires:  (crate(libc) >= 0.2.40 with crate(libc) < 0.3.0)
BuildRequires:  (crate(log) >= 0.4.1 with crate(log) < 0.5.0)
BuildRequires:  (crate(lru_time_cache) >= 0.8.0 with crate(lru_time_cache) < 0.9.0)
BuildRequires:  (crate(maplit) >= 1.0.1 with crate(maplit) < 2.0.0)
BuildRequires:  (crate(mime-sniffer) >= 0.1.2 with crate(mime-sniffer) < 0.2.0)
BuildRequires:  (crate(pretty_env_logger) >= 0.2.2 with crate(pretty_env_logger) < 0.3.0)
BuildRequires:  (crate(rand) >= 0.4.2 with crate(rand) < 0.5.0)
BuildRequires:  (crate(serde) >= 1.0.39 with crate(serde) < 2.0.0)
BuildRequires:  (crate(serde_derive) >= 1.0.39 with crate(serde_derive) < 2.0.0)
BuildRequires:  (crate(serde_json) >= 1.0.15 with crate(serde_json) < 2.0.0)
BuildRequires:  (crate(time) >= 0.1.39 with crate(time) < 0.2.0)
BuildRequires:  (crate(xdg) >= 2.1.0 with crate(xdg) < 3.0.0)
BuildRequires:  (crate(yup-oauth2) >= 1.0.7 with crate(yup-oauth2) < 2.0.0)

%description
%{summary}.

%package     -n %{crate}
Summary:        %{summary}

%description -n %{crate}
%{summary}.

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel
Filesystem based on Google Drive.

This package contains library source intended for building other packages
which use %{crate} from crates.io.

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%files       -n %{crate}
%license LICENSE
%doc README.md sample_config.toml
%{_bindir}/gcsf

%files          devel
%license LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{ci,sample_config.toml}

%changelog
* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.16-1
- Update to 0.1.16

* Thu Jul 26 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.15-1
- Initial package