Blob Blame History Raw
# Generated by rust2rpm
# quickcheck wants rand-0.5, we want rand-0.6
%bcond_with check
%global debug_package %{nil}

%global crate flate2-crc

Name:           rust-%{crate}
Version:        0.1.2
Release:        1%{?dist}
Summary:        SIMD acceleration for CRC-32 checksums used in the gzip format

# Upstream license specification: MIT/Apache-2.0
License:        MIT or ASL 2.0
URL:            https://crates.io/crates/flate2-crc
Source0:        https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(cfg-if/default) >= 0.1.6 with crate(cfg-if/default) < 0.2.0)
%if %{with check}
BuildRequires:  (crate(libz-sys/default) >= 1.0.0 with crate(libz-sys/default) < 2.0.0)
BuildRequires:  (crate(miniz-sys/default) >= 0.1.0 with crate(miniz-sys/default) < 0.2.0)
BuildRequires:  (crate(quickcheck/default) >= 0.7.0 with crate(quickcheck/default) < 0.8.0)
BuildRequires:  (crate(rand/default) >= 0.6.0 with crate(rand/default) < 0.7.0)
BuildRequires:  (crate(rayon/default) >= 1.0.3 with crate(rayon/default) < 2.0.0)
%endif

%global _description \
SIMD acceleration for CRC-32 checksums used in the gzip format.\
**Deprecated in favor of the `crc32fast` crate**

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE-APACHE LICENSE-MIT
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Mon Dec 03 2018 Josh Stone <jistone@redhat.com> - 0.1.2-1
- Update to 0.1.2

* Tue Nov 27 2018 Josh Stone <jistone@redhat.com> - 0.1.1-1
- Initial package