Blob Blame History Raw
# Generated by rust2rpm 10
%bcond_without check
%global debug_package %{nil}

# Binary is pretty useless
%global __cargo_is_bin() false

%global crate difference

Name:           rust-%{crate}
Version:        2.0.0
Release:        15%{?dist}
Summary:        Rust text diffing and assertion library

# Upstream license specification: MIT
License:        MIT
URL:            https://crates.io/crates/difference
Source:         %{crates_source}
# Initial patched metadata
# * Bump term to 0.6, https://github.com/johannhof/difference.rs/pull/42
# * Bump quickcheck to 0.9, https://github.com/johannhof/difference.rs/pull/38
# * Remove bin feature, it is useless
Patch0:         difference-fix-metadata.diff
# Use ..= for an inclusive range instead of deprecated ...
# https://github.com/johannhof/difference.rs/pull/41
Patch1:         https://patch-diff.githubusercontent.com/raw/johannhof/difference.rs/pull/41.patch#/0001-Fix-inclusive-range.patch

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
Rust text diffing and assertion library.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/appveyor.yml

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-15
- Second attempt - Rebuilt for
  https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

* Thu Dec 14 03:15:34 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 2.0.0-12
- Bump term to 0.6

* Fri Sep 13 20:26:35 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 2.0.0-11
- Bump quickcheck to 0.9

* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

* Fri Jun 21 21:38:44 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.0-9
- Regenerate

* Sun Feb 17 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.0-8
- Tests are run in infrastructure

* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Tue Nov 13 2018 Josh Stone <jistone@redhat.com> - 2.0.0-6
- Adapt to new packaging

* Mon Sep 10 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.0-5
- Bump quickcheck to 0.7

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Thu May 10 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.0-3
- Bump term to 0.5

* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

* Wed Jan 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.0.0-1
- Initial package