Blob Blame History Raw
# Generated by rust2rpm 10
%bcond_without check
%global debug_package %{nil}

%global crate askalono

Name:           rust-%{crate}
Version:        0.3.0
Release:        3%{?dist}
Summary:        Library to detect the contents of license files

# Upstream license specification: Apache-2.0
License:        ASL 2.0
URL:            https://crates.io/crates/askalono
Source:         %{crates_source}
# To enable full tests:
# git clone https://github.com/amzn/askalono && cd askalono
# git submodule update --init
# tar -czf rust-askalono-0.3.0-datasets.tgz datasets/
# Source1:        rust-askalono-0.3.0-datasets.tgz
# Initial patched metadata
# * Bump regex to 1.1.2, env_logger to 0.6.1
#   https://github.com/amzn/askalono/commit/e5875f9676fa4a3e43adcf1dae705ef3f508a4a6
Patch0:         askalono-fix-metadata.diff

ExclusiveArch:  %{rust_arches}
%if %{__cargo_skip_build}
BuildArch:      noarch
%endif

BuildRequires:  rust-packaging

%global _description %{expand:
Library to detect the contents of license files.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%doc CHANGELOG.md CODE_OF_CONDUCT.md CONTRIBUTING.md NOTICE README.md
%license LICENSE
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+serde_json-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde_json-devel %{_description}

This package contains library source intended for building other packages
which use "serde_json" feature of "%{crate}" crate.

%files       -n %{name}+serde_json-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+spdx-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+spdx-devel %{_description}

This package contains library source intended for building other packages
which use "spdx" feature of "%{crate}" crate.

%files       -n %{name}+spdx-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
# The complete tests suite needs the dataset submodule
%cargo_test -- -- --skip self_apache_header --skip real_world_licenses --skip empty_match --skip self_licenses --skip store_loads
%endif

%changelog
* Sun Jul 21 10:11:05 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.0-3
- Regenerate

* Thu Apr 11 14:40:21 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.0-2
- Run tests in infrastructure

* Thu Mar 28 09:11:54 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.3.0-1
- Initial package