Blob Blame History Raw
# Generated by rust2rpm
# model and proptest are not packaged yet
%bcond_with check
%global debug_package %{nil}

%global crate arc-swap

Name:           rust-%{crate}
Version:        0.3.5
Release:        1%{?dist}
Summary:        Atomically swappable Arc

# Upstream license specification: Apache-2.0/MIT
License:        ASL 2.0 or MIT
URL:            https://crates.io/crates/arc-swap
Source0:        https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
%if %{with check}
BuildRequires:  (crate(crossbeam-utils/default) >= 0.5.0 with crate(crossbeam-utils/default) < 0.6.0)
BuildRequires:  (crate(itertools/default) >= 0.7.0 with crate(itertools/default) < 0.8.0)
BuildRequires:  (crate(lazy_static/default) >= 1.0.0 with crate(lazy_static/default) < 2.0.0)
BuildRequires:  (crate(model/default) >= 0.0.4 with crate(model/default) < 0.1.0)
BuildRequires:  (crate(num_cpus/default) >= 1.0.0 with crate(num_cpus/default) < 2.0.0)
BuildRequires:  (crate(proptest/default) >= 0.7.0 with crate(proptest/default) < 0.8.0)
BuildRequires:  (crate(version-sync/default) >= 0.5.0 with crate(version-sync/default) < 0.6.0)
%endif

%global _description \
Atomically swappable Arc.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE-APACHE LICENSE-MIT
%doc README.md
%{cargo_registry}/%{crate}-%{version}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Thu Nov 15 2018 Josh Stone <jistone@redhat.com> - 0.3.5-1
- Initial package