Blob Blame History Raw
# Generated by rust2rpm
# addr2line(dev) -> backtrace(opt) -> addr2line
# findshlibs depends on bindgen which is not packaged
%bcond_with check
%global debug_package %{nil}

%global crate addr2line

Name:           rust-%{crate}
Version:        0.8.0
Release:        1%{?dist}
Summary:        Cross-platform symbolication library written in Rust, using `gimli`

# Upstream license specification: Apache-2.0/MIT
License:        ASL 2.0 or MIT
URL:            https://crates.io/crates/addr2line
Source:         %{crates_source}
# Initial patched metadata
# * Drop "alloc" feature, it is nightly-only
Patch0:         addr2line-fix-metadata.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging
BuildRequires:  (crate(cpp_demangle) >= 0.2.0 with crate(cpp_demangle) < 0.3.0)
BuildRequires:  (crate(fallible-iterator) >= 0.1.0 with crate(fallible-iterator) < 0.2.0)
BuildRequires:  (crate(gimli) >= 0.16.1 with crate(gimli) < 0.17.0)
BuildRequires:  (crate(gimli/std) >= 0.16.1 with crate(gimli/std) < 0.17.0)
BuildRequires:  (crate(intervaltree) >= 0.2.0 with crate(intervaltree) < 0.3.0)
BuildRequires:  (crate(intervaltree/std) >= 0.2.0 with crate(intervaltree/std) < 0.3.0)
BuildRequires:  (crate(lazycell/default) >= 1.0.0 with crate(lazycell/default) < 2.0.0)
BuildRequires:  (crate(object) >= 0.11.0 with crate(object) < 0.12.0)
BuildRequires:  (crate(object/std) >= 0.11.0 with crate(object/std) < 0.12.0)
BuildRequires:  (crate(rustc-demangle/default) >= 0.1.0 with crate(rustc-demangle/default) < 0.2.0)
BuildRequires:  (crate(smallvec) >= 0.6.0 with crate(smallvec) < 0.7.0)
BuildRequires:  (crate(smallvec/std) >= 0.6.0 with crate(smallvec/std) < 0.7.0)
%if %{with check}
BuildRequires:  (crate(backtrace/default) >= 0.3.13 with crate(backtrace/default) < 0.4.0)
BuildRequires:  (crate(clap/default) >= 2.0.0 with crate(clap/default) < 3.0.0)
BuildRequires:  (crate(findshlibs/default) >= 0.4.0 with crate(findshlibs/default) < 0.5.0)
BuildRequires:  (crate(memmap/default) >= 0.7.0 with crate(memmap/default) < 0.8.0)
BuildRequires:  (crate(rustc-test/default) >= 0.3.0 with crate(rustc-test/default) < 0.4.0)
%endif

%global _description \
A cross-platform symbolication library written in Rust, using `gimli`.

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages
which use "%{crate}" crate.

%files          devel
%license LICENSE-APACHE LICENSE-MIT
%doc README.md
%{cargo_registry}/%{crate}-%{version}/
%exclude %{cargo_registry}/%{crate}-%{version}/{benchmark.sh,bench.plot.r,coverage,memory.png,time.png}

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+cpp_demangle-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+cpp_demangle-devel %{_description}

This package contains library source intended for building other packages
which use "cpp_demangle" feature of "%{crate}" crate.

%files       -n %{name}+cpp_demangle-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+object-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+object-devel %{_description}

This package contains library source intended for building other packages
which use "object" feature of "%{crate}" crate.

%files       -n %{name}+object-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+rustc-demangle-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+rustc-demangle-devel %{_description}

This package contains library source intended for building other packages
which use "rustc-demangle" feature of "%{crate}" crate.

%files       -n %{name}+rustc-demangle-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages
which use "std" feature of "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
* Sun Feb 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.8.0-1
- Update to 0.8.0

* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Tue Nov 27 2018 Josh Stone <jistone@redhat.com> - 0.7.0-4
- Bump to object 0.11

* Tue Nov 13 2018 Josh Stone <jistone@redhat.com> - 0.7.0-3
- Adapt to new packaging

* Tue Oct 02 2018 Josh Stone <jistone@redhat.com> - 0.7.0-2
- Bump object to 0.10

* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.0-1
- Update to 0.7.0

* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Sat Apr 14 2018 Josh Stone <jistone@redhat.com> - 0.6.0-1
- Update to 0.6.0

* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-2
- Rebuild for rust-packaging v5

* Fri Jan 05 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.5.0-1
- Initial package