Blob Blame History Raw
%global modname repoze.lru

Name:           python-repoze-lru
Version:        0.3
Release:        1%{?dist}
Summary:        A tiny LRU cache implementation and decorator

Group:          Development/Libraries
License:        BSD
URL:            http://pypi.python.org/pypi/repoze.lru
Source0:        http://pypi.python.org/packages/source/r/repoze.lru/%{modname}-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch:      noarch

BuildRequires:  python-setuptools-devel
BuildRequires:  python2-devel

%description
repoze.lru is a LRU (least recently used) cache implementation. Keys and values
that are not used frequently will be evicted from the cache faster than keys
and values that are used frequently.

%prep
%setup -q -n %{modname}-%{version}

%build
%{__python} setup.py build

%install
rm -rf %{buildroot}
%{__python} setup.py install -O1 --skip-build --root %{buildroot}

%check
%{__python} setup.py test

%clean
rm -rf %{buildroot}

%files
%defattr(-,root,root,-)
%doc README.txt LICENSE.txt
%{python_sitelib}/*

%changelog
* Wed Jan  2 2010 Luke Macken <lmacken@redhat.com> - 0.3-1
- Initial package