Blob Blame History Raw
Name:           perl-Algorithm-C3
Version:        0.07
Release:        1%{?dist}
Summary:        Module for merging hierarchies using the C3 algorithm
License:        GPL or Artistic
Group:          Development/Libraries
URL:            http://search.cpan.org/dist/Algorithm-C3/
Source0:        http://www.cpan.org/authors/id/B/BL/BLBLACK/Algorithm-C3-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch:      noarch
Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))

# core
BuildRequires:  perl(Test::More)
# cpan
BuildRequires:  perl(Module::Build)
# for testing....
BuildRequires:  perl(Test::Pod)
BuildRequires:  perl(Test::Pod::Coverage)


%description
This module implements the C3 algorithm.  Most of the uses I have for C3 
revolve around class building and metamodels, but it could also be used for 
things like dependency resolution as well since it tends to do such a nice 
job of preserving local precendence orderings.

%prep
%setup -q -n Algorithm-C3-%{version}

%build
%{__perl} Build.PL installdirs=vendor
./Build

%install
rm -rf %{buildroot}

./Build install destdir=%{buildroot} create_packlist=0
find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;

%{_fixperms} %{buildroot}/*

%check
./Build test

%clean
rm -rf %{buildroot}

%files
%defattr(-,root,root,-)
%doc Changes README t/
%{perl_vendorlib}/*
%{_mandir}/man3/*

%changelog
* Thu May 31 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.07-1
- update to 0.07
- include t/ in doc
- minor spec reworkage to deal with the once and future perl split

* Tue Nov 21 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.06-1
- update to 0.06

* Wed Sep 06 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.05-2
- bump

* Tue Sep 05 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.05-1
- Specfile autogenerated by cpanspec 1.69.1.