Blob Blame History Raw
%{?nodejs_find_provides_and_requires}

%global enable_tests 0

Name:       nodejs-walkdir
Version:    0.0.7
Release:    4%{?dist}
Summary:    Walks a directory tree emitting events based on what it finds
License:    MIT
Group:      System Environment/Libraries
URL:        https://github.com/soldair/node-walkdir
Source0:    http://registry.npmjs.org/walkdir/-/walkdir-%{version}.tgz

BuildArch:  noarch
%if 0%{?fedora} >= 19
ExclusiveArch: %{nodejs_arches} noarch
%else
ExclusiveArch: %{ix86} x86_64 %{arm} noarch
%endif

BuildRequires:  nodejs-packaging

%if 0%{?enable_tests}
BuildRequires:  npm(findit)
BuildRequires:  npm(fstream)
BuildRequires:  npm(ls-r)
BuildRequires:  npm(tap)
%endif

%description
This Node.js module walks a directory tree emitting events based on what it
finds. It presents a familiar callback/emitter/sync interface and can walk a
tree of any depth.


%prep
%setup -q -n package


%build
#nothing to do


%install
mkdir -p %{buildroot}%{nodejs_sitelib}/walkdir
cp -pr package.json walkdir.js \
    %{buildroot}%{nodejs_sitelib}/walkdir

%nodejs_symlink_deps


%if 0%{?enable_tests}
%check
%nodejs_symlink_deps --check
%tap test/*.js
%endif


%files
%doc license readme.md
%{nodejs_sitelib}/walkdir


%changelog
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.7-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

* Tue Aug 20 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 0.0.7-3
- restrict to compatible arches

* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.7-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

* Sat May 25 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 0.0.7-1
- update to upstream release 0.0.7

* Sun Feb 17 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 0.0.5-1
- initial package