Blob Blame History Raw
%global enable_tests 0
%global module_name nested-error-stacks

Name:           nodejs-%{module_name}
Version:        1.0.0
Release:        2%{?dist}
Summary:        An Error subclass that will chain nested Errors and dump nested stacktraces

License:        MIT
URL:            https://github.com/mdlavin/nested-error-stacks
Source0:        http://registry.npmjs.org/%{module_name}/-/%{module_name}-%{version}.tgz

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  nodejs-packaging

%if 0%{?enable_tests}
BuildRequires:  npm(mocha)
BuildRequires:  npm(uuid)
BuildRequires:  npm(chai)
%endif

%description
With this module, you can wrap a caught exception with extra context for
better debugging.

%prep
%setup -q -n package
rm -rf node_modules

%build
# nothing to build

%install
mkdir -p %{buildroot}%{nodejs_sitelib}/%{module_name}
cp -pr package.json index.js %{buildroot}%{nodejs_sitelib}/%{module_name}

%nodejs_symlink_deps

#disable tests as they need network access
%if 0%{?enable_tests}
%check
%nodejs_symlink_deps --check
node_modules/.bin/mocha
%endif

%files
%doc README.md
%license LICENSE
%{nodejs_sitelib}/%{module_name}

%changelog
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild

* Fri Jul 03 2015 Parag Nemade <pnemade AT redhat DOT com> - 1.0.0-1
- Initial packaging