Blob Blame History Raw
%global enable_tests 0
%global module_name got

Name:           nodejs-%{module_name}
Version:        2.2.0
Release:        1%{?dist}
Summary:        Simplified HTTP/HTTPS requests

License:        MIT
URL:            https://github.com/sindresorhus/got
Source0:        https://github.com/sindresorhus/got/archive/v2.2.0.tar.gz
BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  nodejs-packaging

Requires:       npm(object-assign)
Requires:       npm(read-all-stream)
Requires:       npm(timed-out)

%description
Simplified HTTP/HTTPS requests. A nicer interface to the built-in http module.
It also supports following redirects and automagically handling gzip/deflate.

%prep
%setup -q -n %{module_name}-%{version}
rm -rf node_modules

%build
# nothing to build

%install
mkdir -p %{buildroot}%{nodejs_sitelib}/%{module_name}
cp -pr package.json *.js %{buildroot}%{nodejs_sitelib}/%{module_name}
%nodejs_symlink_deps

%if 0%{?enable_tests}
%check
%nodejs_symlink_deps --check
mocha --timeout 50000
%endif

%files
%doc readme.md license
%{nodejs_sitelib}/%{module_name}

%changelog
* Wed Dec 03 2014 Parag Nemade <pnemade AT redhat DOT com> - 2.2.0-1
- Initial packaging