Blob Blame History Raw
%{?nodejs_find_provides_and_requires}

# Disabled as BR: for tests are not in fedora
%global enable_tests 0

%global module_name from

Name:           nodejs-%{module_name}
Version:        0.1.3
Release:        1%{?dist}
Summary:        Easy way to make a Readable Stream

License:        MIT or ASL 2.0
URL:            http://github.com/dominictarr/from
Source0:        http://registry.npmjs.org/%{module_name}/-/%{module_name}-%{version}.tgz
BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  nodejs-packaging

%if 0%{?enable_tests}
BuildRequires:  npm(asynct)
BuildRequires:  npm(stream-spec)
BuildRequires:  npm(assertions)
%endif

%description
%{summary}.

%prep
%setup -q -n package
rm -rf node_modules

%build
# nothing to build

%install
mkdir -p %{buildroot}%{nodejs_sitelib}/%{module_name}
cp -pr package.json index.js %{buildroot}%{nodejs_sitelib}/%{module_name}

%nodejs_symlink_deps

%if 0%{?enable_tests}
%check
%nodejs_symlink_deps --check
asynct test/*.js
%endif

%files
%doc readme.markdown LICENSE.MIT LICENSE.APACHE2
%{nodejs_sitelib}/%{module_name}

%changelog
* Sun Dec 07 2014 Parag Nemade <pnemade AT redhat DOT com> - 0.1.3-1
- Initial packaging