Blob Blame History Raw
%{?nodejs_find_provides_and_requires}

%global enable_tests 1

Name:       nodejs-fileset
Version:    0.1.5
Release:    1%{?dist}
Summary:    A wrapper around glob and minimatch for Node.js
License:    MIT
Group:      System Environment/Libraries
URL:        https://github.com/mklabs/node-fileset
Source0:    http://registry.npmjs.org/fileset/-/fileset-%{version}.tgz
BuildArch:  noarch

BuildRequires:  nodejs-devel

%if 0%{?enable_tests}
BuildRequires:  npm(glob)
BuildRequires:  npm(minimatch)
%endif

%description
This Node.js module exposes a basic wrapper on top of nodejs-glob and
nodejs-minimatch. It adds multiple patterns matching and allows a list
of include patterns and optional exclude patterns.


%prep
%setup -q -n package


%build
#nothing to do


%install
mkdir -p %{buildroot}%{nodejs_sitelib}/fileset
cp -pr package.json lib/ \
    %{buildroot}%{nodejs_sitelib}/fileset

%nodejs_symlink_deps


%if 0%{?enable_tests}
%check
ln -sf %{nodejs_sitelib} .
%__nodejs ./tests/test.js
%endif


%files
%doc LICENSE-MIT README.md
%{nodejs_sitelib}/fileset


%changelog
* Sun Feb 17 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 0.1.5-1
- initial package