Blob Blame History Raw
# This macro is needed at the start for building on EL6
%{?nodejs_find_provides_and_requires}

%global enable_tests 0

%global barename breakable

Name:               nodejs-breakable
Version:            1.0.0
Release:            1%{?dist}
Summary:            Break out of functions

Group:              Development/Libraries
License:            MIT
URL:                https://www.npmjs.org/package/breakable
Source0:            http://registry.npmjs.org/%{barename}/-/%{barename}-%{version}.tgz
BuildArch:          noarch
%if 0%{?fedora} >= 19
ExclusiveArch:      %{nodejs_arches} noarch
%else
ExclusiveArch:      %{ix86} x86_64 %{arm} noarch
%endif

BuildRequires:      nodejs-packaging >= 6



%if 0%{?enable_tests}
BuildRequires:      npm(tap)
%endif


%description
Break out of functions, recursive or not, in a more composable way than by
using exceptions explicitly. Non-local return.

%prep
%setup -q -n package

# Remove bundled node_modules if there are any..
rm -rf node_modules/

%nodejs_fixdep --caret

%build
%nodejs_symlink_deps --build

%install
mkdir -p %{buildroot}%{nodejs_sitelib}/breakable
cp -pr package.json breakable.js \
    %{buildroot}%{nodejs_sitelib}/breakable

%nodejs_symlink_deps


%check
%if 0%{?enable_tests}
%nodejs_symlink_deps --check
tap test/*.js
%endif


%files
%doc README.md LICENSE
%{nodejs_sitelib}/breakable/

%changelog
* Tue Jul 22 2014 Ralph Bean <rbean@redhat.com> - 1.0.0-1
- Initial packaging for Fedora.