Blob Blame History Raw
%{?nodejs_find_provides_and_requires}

Name:           nodejs-ap
Version:        0.2.0
Release:        1%{?dist}
Summary:        Currying in javascript

License:        MIT
URL:            https://www.npmjs.com/package/ap
Source0:        https://registry.npmjs.org/ap/-/ap-%{version}.tgz
# https://github.com/substack/node-ap/pull/6
Source1:        nodejs-ap-license.txt
BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  nodejs-packaging

BuildRequires:  npm(tap)


%description
Currying in javascript. Like .bind() without also setting this.

Function.prototype.bind sets this which is super annoying if you
just want to do currying over arguments while passing this through.


%prep
%autosetup -n package
cp %{SOURCE1} LICENSE
rm -rf node_modules


%build


%install
mkdir -p %{buildroot}%{nodejs_sitelib}/ap
cp -pr package.json index.js %{buildroot}%{nodejs_sitelib}/ap
%nodejs_symlink_deps


%check
%nodejs_symlink_deps --check
%{nodejs_sitelib}/tap/bin/tap.js ./test


%files
%{!?_licensedir:%global license %doc}
%doc README.markdown examples
%license LICENSE
%{nodejs_sitelib}/ap


%changelog
* Thu Dec  3 2015 Tom Hughes <tom@compton.nu> - 0.2.0-1
- Initial build of 0.2.0