Blob Blame History Raw
Name:    konqueror
Version: 17.04.0
Release: 1%{?dist}
Summary: KDE File Manager and Browser

License: GPLv2+ and LGPLv2+ and GFDL
URL:     https://konqueror.org/

%global revision %(echo %{version} | cut -d. -f3)
%if %{revision} >= 50
%global stable unstable
%else
%global stable stable
%endif
Source0: http://download.kde.org/%{stable}/applications/%{version}/src/%{name}-%{version}.tar.xz

## upstream patches

## upstreamable patches

## Fedora specific patches

# handled by qt5-srpm-macros, which defines %%qt5_qtwebengine_arches
%{?qt5_qtwebengine_arches:ExclusiveArch: %{qt5_qtwebengine_arches}}

BuildRequires: desktop-file-utils

BuildRequires: extra-cmake-modules
BuildRequires: cmake(KDED)
BuildRequires: cmake(KF5Activities)
BuildRequires: cmake(KF5Archive)
BuildRequires: cmake(KF5Crash)
BuildRequires: cmake(KF5DocTools)
BuildRequires: cmake(KF5KCMUtils)
BuildRequires: cmake(KF5KDELibs4Support)
BuildRequires: cmake(KF5KHtml)
BuildRequires: cmake(KF5Parts)
BuildRequires: cmake(KF5Su)

BuildRequires: cmake(Qt5Core)
BuildRequires: cmake(Qt5Script)
BuildRequires: cmake(Qt5WebEngine)
BuildRequires: cmake(Qt5Widgets)
BuildRequires: cmake(Qt5X11Extras)

BuildRequires: pkgconfig(zlib)
BuildRequires: libtidy-devel

# translations moved here
Conflicts: kde-l10n < 17.03

Requires:      %{name}-libs%{?_isa} = %{version}-%{release} 
Requires:      hicolor-icon-theme
Requires:      kf5-filesystem

%description
Konqueror allows you to manage your files and browse the web in a
unified interface.

%package devel
Summary:       Development files for %{name}
Requires:      %{name}%{?_isa} = %{version}-%{release}
Requires:      %{name}-libs%{?_isa} = %{version}-%{release}
%description   devel
The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.

%package libs
Summary:       Runtime libraries for %{name}
Requires:      %{name} = %{version}-%{release}
%description libs
%{summary}.

%prep
%autosetup -p1


%build
mkdir %{_target_platform}
pushd %{_target_platform}
%{cmake_kf5} ..
popd

make %{?_smp_mflags} -C %{_target_platform}


%install
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}

%find_lang %{name} --all-name


%check
appstream-util validate-relax --nonet %{buildroot}%{_kf5_datadir}/appdata/org.kde.konqueror.appdata.xml ||:
desktop-file-validate %{buildroot}%{_kf5_datadir}/applications/kfmclient.desktop
desktop-file-validate %{buildroot}%{_kf5_datadir}/applications/kfmclient_html.desktop
desktop-file-validate %{buildroot}%{_kf5_datadir}/applications/kfmclient_war.desktop
desktop-file-validate %{buildroot}%{_kf5_datadir}/applications/konqbrowser.desktop

%post
touch --no-create %{_kf5_datadir}/icons/hicolor &> /dev/null || :
touch --no-create %{_kf5_datadir}/icons/oxygen &> /dev/null || :

%posttrans
gtk-update-icon-cache %{_kf5_datadir}/icons/hicolor &> /dev/null || :
gtk-update-icon-cache %{_kf5_datadir}/icons/oxygen &> /dev/null || :
update-desktop-database -q &> /dev/null ||:

%postun
if [ $1 -eq 0 ] ; then
touch --no-create %{_kf5_datadir}/icons/hicolor &> /dev/null || :
touch --no-create %{_kf5_datadir}/icons/oxygen &> /dev/null || :
gtk-update-icon-cache %{_kf5_datadir}/icons/hicolor &> /dev/null || :
gtk-update-icon-cache %{_kf5_datadir}/icons/oxygen &> /dev/null || :
update-desktop-database -q &> /dev/null ||:
fi

%files -f %{name}.lang
%license COPYING*
%doc AUTHORS ChangeLog
%{_kf5_bindir}/fsview
%{_kf5_bindir}/kfmclient
%{_kf5_bindir}/konqueror
%{_kf5_datadir}/akregator/pics/feed.png
%{_kf5_datadir}/appdata/org.kde.konqueror.appdata.xml
%{_kf5_datadir}/applications/*.desktop
%{_kf5_datadir}/config.kcfg/*.kcfg
%{_kf5_datadir}/dbus-1/interfaces/*.xml
%{_kf5_datadir}/dolphinpart/kpartplugins/*
%{_kf5_datadir}/domtreeviewer/domtreeviewerui.rc
%{_kf5_datadir}/fsview/
%{_kf5_datadir}/icons/hicolor/*/*/*
%{_kf5_datadir}/icons/oxygen/*/*/*
%{_kf5_datadir}/kcmcss/
%{_kf5_datadir}/kcontrol/
%{_kf5_datadir}/kf5/kbookmark/
%{_kf5_datadir}/khtml/
%{_kf5_datadir}/konqueror/
%{_kf5_datadir}/kwebkitpart/
%{_kf5_datadir}/kxmlgui5/konqueror/
%{_kf5_datadir}/kxmlgui5/webenginepart/
%{_kf5_sysconfdir}/xdg/autostart/konqy_preload.desktop
%{_kf5_sysconfdir}/xdg/translaterc
%lang(ca) %{_kf5_datadir}/doc/HTML/ca/*
%lang(da) %{_kf5_datadir}/doc/HTML/da/*
%lang(de) %{_kf5_datadir}/doc/HTML/de/*
%lang(el) %{_kf5_datadir}/doc/HTML/el/*
%lang(en) %{_kf5_datadir}/doc/HTML/en/*
%lang(en_GB) %{_kf5_datadir}/doc/HTML/en_GB/*
%lang(es) %{_kf5_datadir}/doc/HTML/es/*
%lang(et) %{_kf5_datadir}/doc/HTML/et/*
%lang(fr) %{_kf5_datadir}/doc/HTML/fr/*
%lang(it) %{_kf5_datadir}/doc/HTML/it/*
%lang(nb) %{_kf5_datadir}/doc/HTML/nb/*
%lang(nl) %{_kf5_datadir}/doc/HTML/nl/*
%lang(pl) %{_kf5_datadir}/doc/HTML/pl/*
%lang(pt) %{_kf5_datadir}/doc/HTML/pt/*
%lang(pt_BR) %{_kf5_datadir}/doc/HTML/pt_BR/*
%lang(ru) %{_kf5_datadir}/doc/HTML/ru/*
%lang(sr) %{_kf5_datadir}/doc/HTML/sr/*
%lang(sv) %{_kf5_datadir}/doc/HTML/sv/*
%lang(uk) %{_kf5_datadir}/doc/HTML/uk/*

%post libs -p /sbin/ldconfig
%postun libs -p /sbin/ldconfig

%files libs
%{_kf5_datadir}/kservices5/*
%{_kf5_datadir}/kservicetypes5/konqaboutpage.desktop
%{_kf5_libdir}/lib*.so.*
%{_kf5_libdir}/libkdeinit5*.so
%{_kf5_libdir}/libkwebenginepartlib.so
%{_kf5_qtplugindir}/*.so
%dir %{_kf5_plugindir}/parts/
%{_kf5_plugindir}/parts/webenginepart.so

%files devel
%{_kf5_includedir}/konq_*.h
%{_kf5_includedir}/libkonq_export.h
%{_kf5_libdir}/cmake/KF5Konq/
%{_kf5_libdir}/libKF5Konq.so


%changelog
* Tue Apr 18 2017 Rex Dieter <rdieter@fedoraproject.org> - 17.04.0-1
- 17.04.0

* Wed Mar 08 2017 Rex Dieter <rdieter@fedoraproject.org> - 16.12.3-1
- 16.12.3

* Wed Feb 08 2017 Rex Dieter <rdieter@fedoraproject.org> - 16.12.2-1
- 16.12.2

* Fri Jan 20 2017 Christian Dersch <lupinix@mailbox.org> - 16.12.1-1
- initial package (review: RHBZ #1413020)