Blob Blame History Raw
%define isClean 1

%define debug 0

%define build_for_ftp 0

%define strip_bin 0
%define final 0
%define rpm_clean 1

%define desktop_file 1
%define desktop_file_utils_version 0.2.93

%define kde_version 3.1
%define qt_version 3.1.1

%define libtool 0

%define debug_package %{nil}

Name: kdevelop
Summary: Integrated Development Environment for C++/C
Version: 2.1.5
Release: 6
Epoch: 8
URL: http://www.kdevelop.org/
Group: Development/Tools
BuildRoot: %{_tmppath}/%{name}-buildroot
License: GPL

Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}_for_KDE_3.1.tar.bz2
Source1: ftp://129.187.206.68/pub/unix/ide/KDevelop/c_cpp_reference-2.0.2_for_KDE_3.0.tar.bz2
Source2: kdevelop
Source3: kdevelop-htdig.conf

Patch0: kdevelop-2.1beta1-gettext.patch
Patch1: kdevelop-2.0.3-newline.patch
Patch2: kdevelop-2.0.1-font-i18n-20010922.diff
Patch3: kdevelop-2.1-gcc31.patch
Patch4: kdevelop-2.1.3_for_KDE_3.0-redhat.patch
Patch5: kdevelop-2.1.4-ansi.patch
Patch6: kdevelop-2.1.5_for_KDE_3.1-combobox.patch
Patch7: c_cpp_reference-2.0.2-config.patch
Patch8: kde-libtool.patch

Requires: kdelibs-devel >= 6:%{kde_version}
Requires: make
Requires: perl >= 5.004
Requires: autoconf >= 2.13
Requires: automake >= 1.4
Requires: flex >= 2.5.4
Requires: qt-designer >= 1:%{qt_version}

%if %{desktop_file}
BuildPrereq: desktop-file-utils >= %{desktop_file_utils_version}
%endif

%if %{build_for_ftp}
ExclusiveArch: %{ix86}
%endif

BuildPrereq: autoconf
BuildPrereq: automake
BuildPrereq: libtool
BuildPrereq: kdelibs-devel >= %{kde_version}

Obsoletes: kdevelop-c_c++_ref

%description
The KDevelop Integrated Development Environment provides many features
that developers need as well as providing a unified interface to programs
like gdb, the C/C++ compiler, and make. KDevelop manages or provides:

All development tools needed for C++ programming like Compiler,
Linker, automake and autoconf; KAppWizard, which generates complete,
ready-to-go sample applications; Classgenerator, for creating new
classes and integrating them into the current project; File management
for sources, headers, documentation etc. to be included in the
project; The creation of User-Handbooks written with SGML and the
automatic generation of HTML-output with the KDE look and feel;
Automatic HTML-based API-documentation for your project's classes with
cross-references to the used libraries; Internationalization support
for your application, allowing translators to easily add their target
language to a project;

KDevelop also includes WYSIWYG (What you see is what you get)-creation
of user interfaces with a built-in dialog editor; Debugging your
application by integrating KDbg; Editing of project-specific pixmaps
with KIconEdit; The inclusion of any other program you need for
development by adding it to the "Tools"-menu according to your
individual needs.

%prep
%setup -q -n %{name}-%{version}_for_KDE_3.1 -a1

%patch0 -p1 -b .gettext
%patch1 -p1 -b .newline
%patch2 -p1 -b .fonts
%patch3 -p1 -b .gcc31
%patch4 -p1 -b .redhat
%patch5 -p1 -b .ansi
%patch6 -p1 -b .combo
%patch7 -p0 -b .config
%patch8 -p1 -b .libtool

%build
export KDEDIR=%{_prefix}
QTDIR="" && source /etc/profile.d/qt.sh

# Workaround for legacy auto* tools
%if %{libtool}
[ -x /usr/bin/autoconf-2.5? ] && ln -s /usr/bin/autoconf-2.5? autoconf
[ -x /usr/bin/autoheader-2.5? ] && ln -s /usr/bin/autoheader-2.5? autoheader
[ -x /usr/bin/aclocal-1.5 ] && ln -s /usr/bin/aclocal-1.5 aclocal
[ -x /usr/bin/automake-1.5 ] && ln -s /usr/bin/automake-1.5 automake
export PATH=`pwd`:$PATH
make -f Makefile.cvs
%endif

export FLAGS="$RPM_OPT_FLAGS -DNDEBUG -DNO_DEBUG -D_GNU_SOURCE"

%configure \
  --with-qtdoc-dir=$QTDIR/doc/html/ \
  --with-kdelibsdoc-dir=%{_docdir}/kdelibs-devel-3 \
  --with-qt-libraries=$QTDIR/lib \
  --with-extra-libs=%{_libdir}

make %{?smp_mflags}

# c references
pushd c_cpp_reference-2.0.2_for_KDE_3.0
%configure \
  --with-qt-libraries=$QTDIR/lib \
  --with-qt-includes=$QTDIR/include \
  --with-extra-libs=%{_libdir}
popd

%install
rm -rf $RPM_BUILD_ROOT

make DESTDIR=$RPM_BUILD_ROOT install
make -C c_cpp_reference-2.0.2_for_KDE_3.0 DESTDIR=$RPM_BUILD_ROOT install

mv $RPM_BUILD_ROOT%{_bindir}/kdevelop \
   $RPM_BUILD_ROOT%{_bindir}/kdevelop-%{version}

install -m755 %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/
install -m644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/apps/kdevelop/tools/htdig.conf

perl -pi -e "s/\@VERSION\@/%{version}/g" $RPM_BUILD_ROOT%{_bindir}/kdevelop

# start desktop-file-install
%if %{desktop_file}
mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
desktop-file-install --vendor kde \
   --dir $RPM_BUILD_ROOT%{_datadir}/applications \
   --delete-original \
   --add-category "Application;Development;X-Red-Hat-Base" \
   $RPM_BUILD_ROOT%{_datadir}/applnk/Development/kdevelop.desktop

desktop-file-install --vendor kde \
   --dir $RPM_BUILD_ROOT%{_datadir}/applications \
   --delete-original \
   --add-category "Application;Development;X-Red-Hat-Extra" \
   $RPM_BUILD_ROOT%{_datadir}/applnk/Development/kdevelop-setup.desktop
%endif

%files
%defattr(-,root,root)
%doc %{_docdir}/HTML/en/%{name}
%{_bindir}/*
%{_libdir}/libkdevel*
%{_datadir}/apps/%{name}
%{_datadir}/apps/kconf_update/kdevelop2.upd
%{_datadir}/mimelnk/application/*
%if %{desktop_file}
%{_datadir}/applications/*
%else
%{_datadir}/applnk/Development/*
%endif
%{_datadir}/icons/*/*/apps/*
%lang(af) %{_datadir}/locale/af/LC_MESSAGES/kdevelop.mo
%lang(ar) %{_datadir}/locale/ar/LC_MESSAGES/kdevelop.mo
%lang(az) %{_datadir}/locale/az/LC_MESSAGES/kdevelop.mo
%lang(da) %{_datadir}/locale/da/LC_MESSAGES/kdevelop.mo
%lang(de) %{_datadir}/locale/de/LC_MESSAGES/kdevelop.mo
%lang(en_GB) %{_datadir}/locale/en_GB/LC_MESSAGES/kdevelop.mo
%lang(es) %{_datadir}/locale/es/LC_MESSAGES/kdevelop.mo
%lang(et) %{_datadir}/locale/et/LC_MESSAGES/kdevelop.mo
%lang(fi) %{_datadir}/locale/fi/LC_MESSAGES/kdevelop.mo
%lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/kdevelop.mo
%lang(hu) %{_datadir}/locale/hu/LC_MESSAGES/kdevelop.mo
%lang(id) %{_datadir}/locale/id/LC_MESSAGES/kdevelop.mo
%lang(is) %{_datadir}/locale/is/LC_MESSAGES/kdevelop.mo
%lang(it) %{_datadir}/locale/it/LC_MESSAGES/kdevelop.mo
%lang(ja) %{_datadir}/locale/ja/LC_MESSAGES/kdevelop.mo
%lang(lv) %{_datadir}/locale/lv/LC_MESSAGES/kdevelop.mo
%lang(no) %{_datadir}/locale/nb/LC_MESSAGES/kdevelop.mo
%lang(nl) %{_datadir}/locale/nl/LC_MESSAGES/kdevelop.mo
%lang(nn) %{_datadir}/locale/nn/LC_MESSAGES/kdevelop.mo
%lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/kdevelop.mo
%lang(pt) %{_datadir}/locale/pt/LC_MESSAGES/kdevelop.mo
%lang(pt_BR) %{_datadir}/locale/pt_BR/LC_MESSAGES/kdevelop.mo
%lang(ro) %{_datadir}/locale/ro/LC_MESSAGES/kdevelop.mo
%lang(sk) %{_datadir}/locale/sk/LC_MESSAGES/kdevelop.mo
%lang(sl) %{_datadir}/locale/sl/LC_MESSAGES/kdevelop.mo
%lang(sv) %{_datadir}/locale/sv/LC_MESSAGES/kdevelop.mo
%lang(ta) %{_datadir}/locale/ta/LC_MESSAGES/kdevelop.mo
%lang(tr) %{_datadir}/locale/tr/LC_MESSAGES/kdevelop.mo
%lang(vi) %{_datadir}/locale/vi/LC_MESSAGES/kdevelop.mo
%lang(xh) %{_datadir}/locale/xh/LC_MESSAGES/kdevelop.mo
%lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/kdevelop.mo
%lang(zu) %{_datadir}/locale/zu/LC_MESSAGES/kdevelop.mo

%changelog
* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
- rebuilt

* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
- rebuilt

* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
- rebuilt

* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
- rebuilt

* Fri Feb 21 2003 <than@redhat.com> 2.1.5-2
- get rid of gcc path from dependency_libs

* Fri Jan 24 2003 <than@redhat.com> 2.1.5-1
- 2.1.5 release
- update c_cpp_reference
- cleanup sepcfile
- remove templates, which is now in new upstream
- remove unneeded c_cpp_reference-2.0.1-config.patch
- add missing mo files
- fixed #75084, #73128, #70656, #77767, #74425

* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.1.4-6
- rebuilt

* Wed Jan  8 2003 Jeff Johnson <jbj@redhat.com> 2.1.4-5
- don't include -debuginfo files in package.

* Tue Dec 31 2002 Than Ngo <than@redhat.com> 2.1.4-4
- fix templates (bug #80745)

* Tue Dec 17 2002 Than Ngo <than@redhat.com> 2.1.4-3
- enable kdoc

* Mon Dec  9 2002 Than Ngo <than@redhat.com> 2.1.4-2
- fix build problem on s390/s390x
- fix bug #78866

* Sun Nov 10 2002 Than Ngo <than@redhat.com> 2.1.4-1
- update to 2.1.4

* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com> 2.1.3-3.2
- Fixed build for s390x.

* Thu Sep 12 2002 Than Ngo <than@redhat.com> 2.1.3-3.1
- clean up specfile for x86_64/ppc (bug #73862)

* Sun Sep  1 2002 Than Ngo <than@redhat.com> 2.1.3-3
- Add fix to show/hide KaboutKDE and Report Bug menu item over
  KDE Action Restrictions in kdeglobals

* Tue Aug 27 2002 Than Ngo <than@redhat.com> 2.1.3-2
- move kdevelop in X-Red-Hat-Base

* Mon Aug 12 2002 Than Ngo <than@redhat.com> 2.1.3-1
- 2.1.3
- Adapted a patch file to 2.1.3

* Sun Aug  5 2002 Than Ngo <than@redhat.com> 2.1.2-3
- fixed desktop file issue

* Tue Jul 23 2002 Tim Powers <timp@redhat.com>
- build using gcc-3.2-0.1

* Tue Jul 09 2002 Than Ngo <than@redhat.com> 2.1.2-1
- 2.1.2 for kde 3.0.2
- use desktop-file-install

* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
- automated rebuild

* Wed Jun 19 2002 Than Ngo <than@redhat.com> 2.1.1-2
- don't forcibly strip binaries

* Sun Jun  2 2002 Than Ngo <than@redhat.com> 2.1.1-1
- 2.1.1

* Sun May 26 2002 Tim Powers <timp@redhat.com>
- automated rebuild

* Thu May 23 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-3
- Use automake15

* Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.1-2
- Change sonames

* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-1
- final

* Wed Mar 27 2002 Than Ngo <than@redhat.com> 2.1-0.cvs20020326.1
- update

* Wed Mar 20 2002 Than Ngo <than@redhat.com> 2.1rc3-1
- update to 2.1rc3

* Sun Mar 17 2002 Than Ngo <than@redhat.com> 2.1rc2-1
- update to 2.1rc2

* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-3
- rebuild against new kdelibs

* Sun Mar 10 2002 Than Ngo <than@redhat.com> 2.1beta2-2
- fixed Strange characters appear in the output window (bug #59217)
- fixed return-line feed sign in Kdevelop setup tool (bug #55032)

* Wed Mar  8 2002 Than Ngo <than@redhat.com> 2.1beta2-1
- update to 2.1beta2

* Wed Jan 16 2002 Than Ngo <than@redhat.com> 2.1beta1-2
- rebuild against new kdelibs

* Wed Jan  9 2002 Than Ngo <than@redhat.com> 2.1beta1-1
- update to 2.1 beta1
- fix build against gcc 3
- fix some typo bugs
- get rid of libkfile
- update c_cpp_reference to 2.0.1

* Mon Oct 22 2001 Than Ngo <than@redhat.com> 2.0-1
- add patch to show non lattin1 font in build-in editor correct (bug #54457)

* Sat Sep 22 2001 Than Ngo <than@redhat.com> 2.0-2
- fix a bug in creating documentation index when running KDevelop Setup (bug #52760)
- backport some major bugfixes from 2.0.1

* Mon Jul 30 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010730.1
- Don't crash on startup

* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010724.1
- Fix file list

* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.0-0.cvs20010723.1
- Update

* Mon Feb 26 2001 Bernhard Rosenkraenzer <bero@redhat.com>
- Yet another respin - printing was broken.

* Sat Feb 24 2001 Bernhard Rosenkraenzer <bero@redhat.com>
- Update the C/C++ reference guide docs. The older version had a
  couple of examples that won't work with gcc 2.96-*

* Thu Feb 22 2001 Than Ngo <than@redhat.com>
- fix version number

* Wed Feb 21 2001 Than Ngo <than@redhat.com>
- 1.4-respin

* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
- 1.4

* Wed Feb 14 2001 Than Ngo <than@redhat.com>
- update (only bugfixes)
- fix up kdelibs documentation path
- fix a dependency problem with kde-i18n package (Bug #27675)
- add qt-designer into requires

* Sun Feb 11 2001 Than Ngo <than@redhat.com>
- fixed to build on s390

* Tue Feb 06 2001 Than Ngo <than@redhat.com>
- update, only bugfixes

* Wed Jan 24 2001 Than Ngo <than@redhat.com>
- hacked for building of KDE references

* Tue Jan 23 2001 Than Ngo <than@redhat.com>
- work-around to build on alpha

* Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
- Update

* Wed Jan 10 2001 Than Ngo <than@redhat.com>
- update new snapshot, only require KDE2/Qt2

* Fri Dec 22 2000 Than Ngo <than@redhat.com>
- fixed dependency problem with kde-i18n

* Thu Dec 21 2000 Than Ngo <than@redhat.com>
- updated to 1.4beta1 with KDE2 support
- fixed to build on s390
- fixed some broken codes
 
* Fri Dec 8 2000 Than Ngo <than@redhat.com>
- fixed for building on ia64
 
* Wed Nov 15 2000 Than Ngo <than@redhat.com>
- build snapshot 20001112, it works now with KDE2 and kde1-compat
- fix libtool to build on sparc and alpha
- don't use make -j
 
* Sun Aug 13 2000 Than Ngo <than@redhat.com>
- fix kdelibsdoc-dir to show kdelibs-1.1.2 html docu correct
 
* Tue Aug 01 2000 Than Ngo <than@redhat.de>
- add missing ldconfig in %post and %postun section (Bug #14924)
- add missing C references stuff to kdevelop
 
* Sun Jul 30 2000 Than Ngo <than@redhat.de>
- rebuilt against compat-egcs-c++, put KDE1 under /usr
- cleanup specfile
 
* Tue Jul 25 2000 Than Ngo <than@redhat.de>
- fix dependency problem
 
* Wed Jul 19 2000 Than Ngo <than@redhat.de>
- rebuilt against compat-libstdc++
 
* Mon Jul 17 2000 Than Ngo <than@redhat.de>
- install under /usr/share instead /usr/lib/kde1-compat/share,
  fix dependency problem
 
* Sat Jul 15 2000 Than Ngo <than@redhat.de>
- rebuilt with egcs-c++-1.1.2

* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
- automatic rebuild
 
* Mon Jul 03 2000 Than Ngo <than@redhat.de>
- fix docdir
- add requires kdebase
 
* Sun Jul 02 2000 Than Ngo <than@redhat.de>
- rebuilt with  kde1-compat
 
* Sun Jun 18 2000 Than Ngo <than@redhat.de>
- rebuilt in the new build environment, fix docdir
- FHS packaging
 
* Thu Jun 08 2000 Than Ngo <than@redhat.de>
- update to 1.2
- move from powertools to main CD
- use %%configure
 
* Mon Apr 3 2000 Ngo Than <than@redhat.de>
- fix up reference (Bug #10368)
 
* Tue Feb 15 2000 Bernhard Rosenkränzer <bero@redhat.com>
- Fix up documentation path (Bug #7291)
- Update to current stable branch - this should fix up the debugger problem
- clean up spec file
 
* Fri Jan  6 2000 Bernhard Rosenkränzer <bero@redhat.com>
- Update to current stable branch
- Adapt to 6.2 Qt libraries
- Use BuildPrereq
 
* Wed Jan 05 2000 Ngo Than <than@redhat.de>
- added patch for alpha
 
* Tue Dec 21 1999 Ngo Than <than@redhat.de>
- updated kdevelop-1.0 release
 
* Tue Nov 16 1999 Preston Brown <pbrown@redhat.com>
- kdevelop 1.0beta4.1, docdir added, using DESTDIR env. variable.
 
* Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
- initial packaging for 6.1.