Blob Blame History Raw
Name:           hawaii-shell
Summary:        Hawaii shell for desktop, netbook and tablet
Version:        0.2.0.2
Release:        1%{?dist}
Group:          Applications/System
License:        BSD and LGPLv2+ and GPLv2+
URL:            https://github.com/hawaii-desktop/shell
Source0:        http://downloads.sourceforge.net/mauios/%{name}-%{version}.tar.gz
Patch1:         0001-shell-Use-default-wallpaper.patch
Patch3:         0001-Use-external-QtXdg.patch

BuildRequires:  pkgconfig(Qt5Core)
BuildRequires:  pkgconfig(Qt5DBus)
BuildRequires:  pkgconfig(Qt5Gui)
BuildRequires:  pkgconfig(Qt5Network)
BuildRequires:  pkgconfig(Qt5Qml)
BuildRequires:  pkgconfig(Qt5Quick)
BuildRequires:  pkgconfig(Qt5Widgets)
BuildRequires:  pkgconfig(Qt5Compositor)
BuildRequires:  pkgconfig(liblzma)
BuildRequires:  pkgconfig(pixman-1)
BuildRequires:  pkgconfig(polkit-qt-1)
BuildRequires:  pkgconfig(wayland-client)
BuildRequires:  pkgconfig(wayland-server)
BuildRequires:  pkgconfig(weston)
BuildRequires:  pkgconfig(xkbcommon)
BuildRequires:  bzip2-devel
BuildRequires:  cmake
BuildRequires:  qt5-qtaccountsservice-devel >= 0.1.1
BuildRequires:  qt5-qtconfiguration-devel >= 0.2.1
BuildRequires:  greenisland-devel >= 0.2.0
BuildRequires:  pkgconfig(glesv2) pkgconfig(egl)
BuildRequires:  alsa-lib-devel

BuildRequires:  dconf-devel
BuildRequires:  glib2-devel
BuildRequires:  libqtxdg-qt5-devel

Requires:       qt5-qtsvg
Requires:       qt5-qttools
Requires:       qt5-qtdeclarative
Requires:       fluid
Requires:       greenisland
Requires:       desktop-backgrounds-compat
Requires:       weston

%description
This is the Hawaii desktop environment shell. It contains a Qt platform plugin 
and shells for different form factors such as desktop, netbook and tablet. Only 
the desktop shell is implemented at the moment though.


%prep
%setup -q
%patch1 -p1
%patch3 -p1


%build
# We use private QtComposior API
CXXFLAGS="%{optflags}"
CXXFLAGS="$CXXFLAGS -I%{_qt5_headerdir}/QtCompositor/5.1.0/QtCompositor"
CXXFLAGS="$CXXFLAGS -I%{_qt5_headerdir}/QtCompositor/5.1.0"
%cmake -DQTWAYLAND_SCANNER_EXECUTABLE=%{_qt5_bindir}/qtwaylandscanner .
make %{?_smp_mflags}


%install
make install DESTDIR=%{buildroot}


%files
%{_bindir}/hawaii
%{_bindir}/hawaii-shell
%{_libdir}/libHawaiiCore.so.*
%exclude %{_libdir}/libHawaiiCore.so
%dir %{_libdir}/hawaii
%dir %{_libdir}/hawaii/qml
%dir %{_libdir}/hawaii/qml/Hawaii
%{_libdir}/hawaii/qml/Hawaii/Shell
%dir %{_libdir}/hawaii/plugins
%dir %{_libdir}/hawaii/plugins/platformthemes
%{_libdir}/hawaii/plugins/platformthemes/hawaii.so
%{_libdir}/weston/hawaii-desktop.so
%{_libexecdir}/starthawaii
%{_libexecdir}/hawaii-desktop-shell
%dir %{_datadir}/hawaii
%dir %{_datadir}/hawaii/styles
%{_datadir}/hawaii/styles/Aluminium
%doc AUTHORS
%doc COPYING
%doc COPYING.LIB
%doc README.md


%changelog
* Sat Jan 04 2014 Lubomir Rintel <lkundrak@v3.sk> - 0.2.0.2-1
- Update to new release tarball

* Sun Nov 24 2013 Lubomir Rintel <lkundrak@v3.sk> - 0.1.95-1
- Bump

* Tue Sep 24 2013 Lubomir Rintel <lkundrak@v3.sk> - 0.1.93-1.20130822gitff4ed81
- Bump

* Mon Sep 16 2013 Lubomir Rintel <lkundrak@v3.sk> - 0.1.91-1.20130804git5624ac7
- Initial packaging