Blob Blame History Raw
# Generated by go2rpm 1
%bcond_without check

# https://github.com/tomnomnom/gron
%global goipath         github.com/tomnomnom/gron
Version:                0.6.0

%gometa

%global common_description %{expand:
gron transforms JSON into discrete assignments to make it easier to grep for
what you want and see the absolute 'path' to it. It eases the exploration of
APIs that return large blobs of JSON.}

%global golicenses      LICENSE
%global godocs          docs CHANGELOG.mkd README.mkd

Name:           gron
Release:        4%{?dist}
Summary:        Make JSON greppable

License:        MIT
URL:            %{gourl}
Source0:        %{gosource}
Source1:        %{name}.1

BuildRequires:  golang(github.com/fatih/color)
BuildRequires:  golang(github.com/mattn/go-colorable)
BuildRequires:  golang(github.com/nwidger/jsoncolor)
BuildRequires:  golang(github.com/pkg/errors)

%description
%{common_description}

%gopkg

%prep
%goprep

%build
%gobuild -o %{gobuilddir}/bin/gron %{goipath}

%install
%gopkginstall
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/

# install manpages
install -d %{buildroot}%{_mandir}/man1
install -m 644 %{SOURCE1} %{buildroot}%{_mandir}/man1

%if %{with check}
%check
%gocheck
%endif

%files
%license LICENSE
%doc docs CHANGELOG.mkd README.mkd
%{_bindir}/*
%{_mandir}/man1/*.1*

%gopkgfiles

%changelog
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

* Fri Jan 03 15:44:23 UTC 2020 Lars Kiesow <lkiesow@uos.de> - 0.6.0-2
- Rebuild using go2rpm

* Mon Jul 30 2018 Lars Kiesow <lkiesow@uos.de> - 0.6.0-1
- Update to gron 0.6.0

* Sun Apr 22 2018 Lars Kiesow <lkiesow@uos.de> - 0.5.2-1
- Initial build