Blob Blame History Raw
# Generated by go2rpm 1
%bcond_without check

# https://github.com/golang/mod
%global goipath         golang.org/x/mod
%global forgeurl        https://github.com/golang/mod
Version:                0.2.0

%gometa

%global common_description %{expand:
This packages holds packages for writing tools that work directly with Go module
mechanics. That is, it is for direct manipulation of Go modules themselves.}

%global golicenses      LICENSE PATENTS
%global godocs          README

Name:           %{goname}
Release:        1%{?dist}
Summary:        Go module mechanics libraries

# Upstream license specification: BSD-3-Clause
License:        BSD
URL:            %{gourl}
Source0:        %{gosource}

BuildRequires:  golang(golang.org/x/crypto/ed25519)
BuildRequires:  golang(golang.org/x/xerrors)

%description
%{common_description}

%gopkg

%prep
%goprep

%build
for cmd in gosumcheck; do
  %gobuild -o %{gobuilddir}/bin/$(basename $cmd) %{goipath}/$cmd
done

%install
%gopkginstall
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/

%if %{with check}
%check
# sumdb/tlog: needs network
%gocheck -d sumdb/tlog
%endif

%files
%license LICENSE PATENTS
%doc README
%{_bindir}/*

%gopkgfiles

%changelog
* Wed Feb 05 18:57:56 CET 2020 Robert-André Mauchin <zebob.m@gmail.com> - 0.2.0-1
- Update to 0.2.0

* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

* Thu Jul 25 12:32:47 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.1.0-1
- Initial package