Blob Blame History Raw
# Generated by go2rpm
%ifarch x86_64
%bcond_without check
%endif

# https://github.com/golang/mobile
%global goipath         golang.org/x/mobile
%global forgeurl        https://github.com/golang/mobile
%global commit          3e0bab5405d63a8f5dd9d9764a24c8e5ac4997fa

%gometa

%global common_description %{expand:
The Go mobile repository holds packages and build tools for using Go on mobile
platforms.}

%global golicenses      LICENSE PATENTS
%global godocs          doc example AUTHORS CONTRIBUTING.md CONTRIBUTORS README.md

Name:           %{goname}
Version:        0
Release:        0.3%{?dist}
Summary:        Go support for Mobile devices

# Upstream license specification: BSD-3-Clause
License:        BSD
URL:            %{gourl}
Source0:        %{gosource}

BuildRequires:  golang(golang.org/x/image/draw)
BuildRequires:  golang(golang.org/x/image/math/f64)
# Tests
BuildRequires:  pkgconfig(egl)
BuildRequires:  pkgconfig(glesv2)

%description
%{common_description}

%gopkg

%prep
%goprep

%build
for cmd in cmd/* ; do
  %gobuild -o %{gobuilddir}/bin/$(basename $cmd) %{goipath}/$cmd
done

%install
%gopkginstall
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/

%if %{with check}
%check
%gocheck
%endif

%files
%license %{golicenses}
%doc %{godocs}
%{_bindir}/*

%gopkgfiles

%changelog
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0-0.3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0-0.2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

* Thu Apr 25 01:09:12 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0-0.1.20190623git3e0bab5
- Initial package