Blob Blame History Raw
# Generated by go2rpm
%bcond_without check

# https://github.com/golang/lint
%global goipath         golang.org/x/lint
%global forgeurl        https://github.com/golang/lint
%global commit          959b441ac422379a43da2230f62be024250818b0

%gometa

%global goaltipaths     github.com/golang/lint

%global common_description %{expand:
Golint is a linter for Go source code.}

%global golicenses      LICENSE
%global godocs          CONTRIBUTING.md README.md

Name:           %{goname}
Version:        0
Release:        0.2%{?dist}
Summary:        Linter for Go source code

# Upstream license specification: BSD-3-Clause
License:        BSD
URL:            %{gourl}
Source0:        %{gosource}

BuildRequires:  golang(golang.org/x/tools/go/ast/astutil)
BuildRequires:  golang(golang.org/x/tools/go/gcexportdata)

Obsoletes:      golint < 0-0.11.gitc7bacac
Provides:       golint = %{version}-%{release}

%description
%{common_description}

%gopkg

%prep
%goprep

%build
for cmd in golint; do
  %gobuild -o %{gobuilddir}/bin/$(basename $cmd) %{goipath}/$cmd
done

%install
%gopkginstall
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/

%if %{with check}
%check
%gocheck
%endif

%files
%license LICENSE
%doc CONTRIBUTING.md README.md
%{_bindir}/*

%gopkgfiles

%changelog
* Tue Jun 25 20:30:06 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0-0.2.20190625git959b441
- Add Provides/Obsoletes

* Mon Apr 29 16:51:10 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0-0.1.20190625git959b441
- Initial package