Blob Blame History Raw
# Generated by go2rpm
%bcond_without check

# https://github.com/mvdan/xurls
%global goipath         mvdan.cc/xurls
%global forgeurl        https://github.com/mvdan/xurls
Version:                2.2.0

%gometa

%global goaltipaths     github.com/mvdan/xurls mvdan.cc/xurls/v2

%global common_description %{expand:
Extract urls from text using regular expressions. Requires Go 1.10.3 or later.}

%global golicenses      LICENSE
%global godocs          README.md

Name:           %{goname}
Release:        2%{?dist}
Summary:        Extract urls from text

# Upstream license specification: BSD-3-Clause
License:        BSD
URL:            %{gourl}
Source0:        %{gosource}

%if %{with check}
# Tests
BuildRequires:  golang(github.com/rogpeppe/go-internal/testscript)
%endif

%description
%{common_description}

%gopkg

%prep
%goprep

%build
for cmd in cmd/* ; do
  %gobuild -o %{gobuilddir}/bin/$(basename $cmd) %{goipath}/$cmd
done

%install
%gopkginstall
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/

%if %{with check}
%check
%gocheck -d cmd/xurls
%endif

%files
%license LICENSE
%doc README.md
%{_bindir}/*

%gopkgfiles

%changelog
* Fri Aug 07 21:26:12 CEST 2020 Robert-André Mauchin <zebob.m@gmail.com> - 2.2.0-2
- Add alternate import path

* Thu Aug 06 22:43:35 CEST 2020 Robert-André Mauchin <zebob.m@gmail.com> - 2.2.0-1
- Update to 2.2.0

* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild

* Sun Feb 16 2020 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 2.1.0-1
- Update to latest version

* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

* Sat May 18 21:32:37 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 2.0.0-1
- Initial package