Blob Blame History Raw
# Generated by go2rpm
%bcond_without check

# https://github.com/neurosnap/sentences
%global goipath         gopkg.in/neurosnap/sentences.v1
%global forgeurl        https://github.com/neurosnap/sentences
Version:                1.0.6

%gometa

# Remove in F33
%global godevelheader %{expand:
Obsoletes:      golang-github-neurosnap-sentences-devel < 1.0.6-6
Obsoletes:      golang-github-neurosnap-sentences-unit-test-devel < 1.0.6-6
}

%global common_description %{expand:
This command line utility will convert a blob of text into a list of sentences.}

%global golicenses      LICENSE.md
%global godocs          CHANGES.md README.md

Name:           %{goname}
Release:        9%{?dist}
Summary:        Multilingual command line sentence tokenizer in Golang

License:        MIT
URL:            %{gourl}
Source0:        %{gosource}

%if %{with check}
# Tests
BuildRequires:  golang(github.com/spf13/cobra)
%endif

# Remove in F33
Obsoletes:      golang-github-neurosnap-sentences < 1.0.6-6

%description
%{common_description}

%gopkg

%prep
%goprep
find . -name "*.go" -exec sed -i "s|github.com/neurosnap/sentences|gopkg.in/neurosnap/sentences.v1|" "{}" +;

%build
for cmd in _cmd/sentences; do
  %gobuild -o %{gobuilddir}/bin/$(basename $cmd) %{goipath}/$cmd
done

%install
%gopkginstall
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/

%if %{with check}
%check
%gocheck
%endif

%files
%license LICENSE.md
%doc CHANGES.md README.md
%{_bindir}/*

%gopkgfiles

%changelog
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.6-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.6-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

* Wed Jul 10 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 1.0.6-7
- Add Obsoletes for old names

* Sat Jun 01 22:05:16 CEST 2019 Robert-André Mauchin <zebob.m@gmail.com> - 1.0.6-6
- Update to new macros

* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.6-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.6-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.6-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

* Fri Sep 08 2017 Athos Ribeiro <athoscr@fedoraproject.org> - 1.0.6-2
- Add Provides under the gopkg.in namespace

* Fri Aug 18 2017 Athos Ribeiro <athoscr@fedoraproject.org> - 1.0.6-1
- First package for Fedora