Blob Blame History Raw
Summary: EFI Boot Manager
Name: efibootmgr
Version: 0.7.0
Release: 4%{?dist}
Group: System Environment/Base
License: GPLv2+
URL: https://github.com/vathpela/%{name}/
BuildRequires: pciutils-devel, zlib-devel, git
BuildRequires: efivar-libs efivar-devel
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXXXX)
# EFI/UEFI don't exist on PPC
ExclusiveArch: i386 x86_64 aarch64
Requires: efivar-libs >= 0.8

# for RHEL / Fedora when efibootmgr was part of the elilo package
Conflicts: elilo < 3.6-6
Obsoletes: elilo < 3.6-6

Source0: https://github.com/vathpela/%{name}/archive/%{name}-%{version}.tar.bz2
Patch0001: 0001-Filenames-and-github-the-worst-of-both-worlds.patch
Patch0002: 0002-Get-a-lot-more-picky-with-our-compiler-warnings.patch
Patch0003: 0003-Add-support-for-displaying-NVME-device-paths.patch
Patch0004: 0004-Make-nvme-work-with-e-3.patch
Patch0005: 0005-Remove-bogus-test-for-optional-data-length-bounds.patch
Patch0006: 0006-Only-free-hard-drive-signatures-if-we-ve-allocated-t.patch
Patch0007: 0007-We-don-t-actually-have-docbook-hooked-up-to-the-buil.patch
Patch0008: 0008-Mitigate-apple-setting-invalid-attribute-bits-in-boo.patch
Patch0009: 0009-Remove-unused-function-var_num_from_name.patch
Patch0010: 0010-Fix-typo-in-compare-function.patch
Patch0011: 0011-data_size-in-construct_boot_order-set_boot_order-is-.patch
Patch0012: 0012-Variable-needed-should-be-of-type-ssize_t-as-that-s-.patch
Patch0013: 0013-Clang-uses-C99-semantics-by-default-for-inline-keywo.patch
Patch0014: 0014-Use-PRIx64-in-nvme-parsing.patch
Patch0015: 0015-Compare-should-respect-the-size-of-the-data-it-compa.patch
Patch0016: 0016-Don-t-pass-around-a-format-specifier-when-we-don-t-n.patch
Patch0017: 0017-Don-t-leak-memory-in-remove_from_boot_order.patch
Patch0018: 0018-Fix-some-leaked-memory-that-shows-up-in-valgrind.patch
Patch0019: 0019-Add-the-ability-to-clean-up-duplicates-in-BootOrder.patch
Patch0020: 0020-Clean-up-some-whitespace.patch
Patch0021: 0021-Move-TODO-stuff-to-0.9.patch
Patch0022: 0022-Fix-some-minor-errors-cppcheck-found.patch

%description
%{name} displays and allows the user to edit the Intel Extensible
Firmware Interface (EFI) Boot Manager variables.  Additional
information about EFI can be found at
http://developer.intel.com/technology/efi/efi.htm and http://uefi.org/.

%prep
%setup -q
git init
git config user.email "shim-owner@fedoraproject.org"
git config user.name "Fedora Ninjas"
git add .
git commit -a -q -m "%{version} baseline."
git am %{patches} </dev/null

%build
make %{?_smp_mflags} EXTRA_CFLAGS='%{optflags}'
%install
rm -rf %{buildroot}
mkdir -p %{buildroot}%{_sbindir} %{buildroot}%{_mandir}/man8
install -p --mode 755 src/%{name}/%{name} %{buildroot}%{_sbindir}
gzip -9 -c src/man/man8/%{name}.8 > src/man/man8/%{name}.8.gz
touch -r src/man/man8/%{name}.8 src/man/man8/%{name}.8.gz
install -p --mode 644 src/man/man8/%{name}.8.gz %{buildroot}%{_mandir}/man8

%clean
rm -rf %{buildroot}

%files
%defattr(-,root,root,-)
%{_sbindir}/%{name}
%{_mandir}/man8/%{name}.8.gz
%doc README INSTALL COPYING
    
%changelog
* Fri Aug 01 2014 Peter Jones <pjones@redhat.com> - 0.7.0-4
- Rebase to current upstream master (in preperation for 0.8.0)

* Thu Jun 19 2014 Peter Jones <pjones@redhat.com> - 0.7.0-3
- Reinstate an accidentally dropped hack to avoid apple brain damage.

* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

* Tue Apr 01 2014 Peter Jones <pjones@redhat.com> - 0.7.0-1{?dist}
- Release 0.7

* Mon Jan 13 2014 Peter Jones <pjones@redhat.com> - 0.6.1-1
- Release 0.6.1

* Mon Jan 13 2014 Jared Dominguez <Jared_Dominguez@dell.com>
- new home https://github.com/vathpela/efibootmgr

* Thu Jan  3 2008 Matt Domsch <Matt_Domsch@dell.com> 0.5.4-1
- split efibootmgr into its own RPM for Fedora/RHEL.

* Thu Aug 24 2004 Matt Domsch <Matt_Domsch@dell.com>
- new home linux.dell.com

* Fri May 18 2001 Matt Domsch <Matt_Domsch@dell.com>
- See doc/ChangeLog